Support » Plugin: SEO Ultimate » 3.6 compatability

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jeffrey L. Smith

    (@seo-design-solutions)

    We just hired new dev team and they are swishing bugs now… give us about 2 weeks.

    Jeffrey L. Smith, hello! I am a new member of wordpress and I searched for the best SEO plugin and your plugin “SEO Ultimate” – is the best of the best! But one problem, I have WordPress 3.6.1 and the last update of your plugin was in January, I had already been upset and wanted to install another good plugin “SEO by Yoast” until I saw this topic and your message about update in 2 weeks, and I’m ready to wait despite the fact that the plugin from Yoast has translated into Russian (and many other languages​​), and updated almost every month.
    Can you exactly tell me when will you update your plugin? Or it’s better to install another one?
    Thank You and Best Regards!
    P.S. I read somewhere that you need a financial help so why not to make a “Donate” button and a lot of people (including myself) will be ready to help..

    Violent, this has been a great plugin, with the primary benefit over other SEO plugins being that it has “deeplink juggernaut” which allows automatic linking of keyphrases from articles into the main pages of your site.

    I’ve been waiting, somewhat patiently, for this to be updated, but am getting a bit worried about not being able to update to the latest WP (worried for security reasons).

    I’m thinking about going with another and just see about using the Velvet Blues plugin to rewrite phrases into linked phrases… it wouldn’t be as good as this one being updated of course, but at some point it might be an option.

    jckbco, so what SEO plugin can you recommend me like this one? Or it will be better to wait for update of SEO Ultimate?

    @violent, I don’t think it would be appropriate for me to mention SEO Ultimate’s competitors here. Google it and you can see the top 2 or 3. Your question of whether it is better to wait is kind of up to the developer… I thought it was, because I have it installed on several sites, so I’ve waited. If there is a security breach because of having an outdated version of WordPress it will have been a bad decision.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘3.6 compatability’ is closed to new replies.