WordPress.org

Ready to get started?Download WordPress

Forums

User Activation Keys
3.6 ? (7 posts)

  1. TeaMike
    Member
    Posted 1 year ago #

    just installed this but clicking the delete uncecessary key doesn't actually delete it, just refresh the page?

    http://wordpress.org/plugins/user-activation-keys/

  2. David Sader
    Member
    Plugin Author

    Posted 1 year ago #

    I knew I forgot to upload something a few months back. lol

    I do have a fixed version of this plugin that I'll push to the plugin repo in a few days.

  3. David Sader
    Member
    Plugin Author

    Posted 1 year ago #

    Actually, I just downloaded the current version of the plugin(3.5.1) and it still works for me. Keys delete as I expect. Just tried it on a batch of recent registrations and it worked.

    I have this plugin installed on an up-to-date WP multisite network.

    Any other troubleshooting information you can provide?

  4. okso
    Member
    Posted 1 year ago #

    Hi David,
    Just found I experience the same issue. I have .php in mu-plugins on MU. Delete key just refreshed page without effect.
    wp3.6.1 MU

    When you say it worked for you, was that on removal of subsite key, or root site I wonder?

  5. DesktopMasters
    Member
    Posted 6 months ago #

    I am having this refresh issue trying to remove a key using the username of temp and temp@desktopmasters.com while temp1 and temp1@desktopmasters.com seems to work fine. Also.. "uncecessary" is actually spelled "unnecessary". You have a typo in your interface.

    THANK YOU for this amazing app. It has made my life so much better. (:

  6. DesktopMasters
    Member
    Posted 6 months ago #

    Update, while testing my registration I got a temp1 account that does the same thing. There is something in random accounts that is preventing them from being deleted. I would be happy to work with you on this and give you direct access to troubleshoot.

  7. David Sader
    Member
    Plugin Author

    Posted 6 months ago #

    Yeah, there was something wonky there. So, I slimmed down some of the code in the plugin. I have it working reliably the way I use it so I have it updated in the WordPress Plugin page now.

    Updated plugin to v3.5.2
    Tested up to: WP 3.9.2, removed batch delete, improved deleting an individual user key.

    I don't use the batch delete buttons, so I just commented them out. Can't be too many peeps using them because they don't seem to work reliably. I only ever approve or delete a user activation key one at a time anyway.

    (I left the old code commented to compare if you are into that. )

    Post here again if it still does't do what you expect.

    (The sites I manage have a flood of new signups with the start of each new school year, so it takes a while to spot the bugs when they pop up.)

    Thanks your your post.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.