WordPress.org

Forums

[resolved] 3.5.2 Update Issues (21 posts)

  1. Cloudrunner
    Member
    Posted 1 year ago #

    I logged on to http://dkdiaries.com/wp-admin.

    I did the update and got the message:

    "Database Update Required

    WordPress has been updated! before we send you on your way, we have to update your database to the newest version.

    The update process process may take a little while, so please be patient."

    I clicked the button that says "Update WordPress Database" and was sent to a page that bears only the WordPress logo. There's no progress bar, nothing that indicates that any action is taking place.

    I have done this repeatedly along with clearing my Mozilla Firefox browser history, but I find myself always getting stuck on the WordPress logo page.

    I can't post or even go to the admin page. Please help.

  2. Tara
    Member
    Posted 1 year ago #

    Try maual update. Read the Manual Update directions first!

  3. Cloudrunner
    Member
    Posted 1 year ago #

    I have tried manually updating. I am still experiencing the same issues.

  4. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Your site seems to be working. Is this where you are trying to login?

    http://www.dkdiaries.com/wp-login.php

  5. Cloudrunner
    Member
    Posted 1 year ago #

    Yes

  6. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Where is your site hosted? Have you asked them?

  7. nocabt
    Member
    Posted 1 year ago #

    Same exact problem here. upgraded a couple sites and all fine except one failed with this exact issue. I'm still investigating it, I'll post back here if I figure it out.

  8. nocabt
    Member
    Posted 1 year ago #

    Right after I posted that I tried increasing WP_MEMORY_LIMIT in wp-config.php, and it upgraded fine.

    Hope that helps you Cloudrunner.

  9. Cloudrunner
    Member
    Posted 1 year ago #

    @WPyogi, I have yet to contact Bluehost about the issue.

    @nocabt, I followed your suggestion but it didn't work for me.

  10. nocabt
    Member
    Posted 1 year ago #

    My gut tells me it's a memory issue still, I used:

    define('WP_MEMORY_LIMIT', '128M');

    and you can increase PHP Memory Limit in .htaccess or local php.ini file (I think the latter on Bluehost as PHP is running as CGI?). Here are a couple help pages from bluehost:

    https://my.bluehost.com/cgi/help/memory
    https://my.bluehost.com/cgi/help/557

  11. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Try replacing upgrade.php (after deleting it) from a fresh download of WordPress and try again.

  12. Cloudrunner
    Member
    Posted 1 year ago #

    #nocabt,

    here's what in my php.ini file:

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    memory_limit = 128M ; Maximum amount of memory a script may consume (16MB)

  13. Cloudrunner
    Member
    Posted 1 year ago #

    @Krishan, did what you told me to do and still the same issue. Just a white page with only the WordPress logo.

    I'll check for any more tips and suggestions when it's daylight. It's 1:36 AM here and I really need to retire for the night. It's been a frustrating day.

  14. nocabt
    Member
    Posted 1 year ago #

    Have you verified those values are being applied by creating a simple PHP info page:

    <?php phpinfo(); ?>

    then making sure the local value column contains 128M for "memory_limit"?

  15. wpmhweb
    Member
    Posted 1 year ago #

    I had exactly the same problem using

    define('WP_MEMORY_LIMIT', '128M');

    in my wp-config.php solve my problem.

    Nothing else to add here, just wanted to back @nocabt solution.

    Thanks,

  16. Cloudrunner
    Member
    Posted 1 year ago #

    Well, guess what? I changed db_version in the wp_options table to "22442" (as suggested in other threads) and I can now access my admin page.

    But now I have a new problem:

    Tried to add a new post. Could write a title but not the body. Missing toolbars and such.

  17. Cloudrunner
    Member
    Posted 1 year ago #

    Alright, I re-installed 3.5.2 from the Dashboard. Things are back to normal. I appreciate all the responses I got.

    This is the first time I've ever experienced WordPress update problems and I hope I don't ever have to jump through this many hoops again in the future.

  18. Cloudrunner
    Member
    Posted 1 year ago #

    Ugh, forgot to mark this topic as resolved in previous comment.

  19. kinesgirl
    Member
    Posted 1 year ago #

    I am having the same problem; I can't access to my wp-admin page because I am automatically directed to the "Database Update Required" page.

    Cloudrunner, where do you find the db_version that you changed?

  20. Tara
    Member
    Posted 1 year ago #

    @kinesgirl: note that this is a "resolved" thread. You will likely get more attention to your inquiry if you start a new thread.

    having said that, here is where you can find DB versions.

    http://codex.wordpress.org/WordPress_Versions

  21. Eleven Sites
    Member
    Posted 1 year ago #

    Hi all,

    Cloudrunner's solution worked for me:

    -Change wp_options > db_version and then re-install the WP install.

    I'll add that I've been experiencing this issue with regard to the 3.5.2 update on sites hosted on BlueHost. I'd like to know if other people are having this issue with other hosting services?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags