WordPress.org

Forums

[resolved] 3.5 update problems (8 posts)

  1. louiepsp
    Member
    Posted 2 years ago #

    Hi I am running wp3.5 with buddypress, after updating today I am getting this error on my albums page...

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/offli342/public_html/testarealouie.cu.cc/wp-content/plugins/bp-gallery/includes/bpa.classes.php on line 371 and defined in /home/offli342/public_html/testarealouie.cu.cc/wp-includes/wp-db.php on line 990
    
    Warning: Missing argument 2 for wpdb::prepare(), called in /home/offli342/public_html/testarealouie.cu.cc/wp-content/plugins/bp-gallery/includes/bpa.classes.php on line 342 and defined in /home/offli342/public_html/testarealouie.cu.cc/wp-includes/wp-db.php on line 990

    any help would be appreciated guys :) thanks.

  2. mikeday1uk
    Member
    Posted 2 years ago #

    I'm getting a similar error on upgrade to 3.5 running Pressworks:

    Warning: Missing argument 2 for wpdb::prepare(), called in /homepages/39/d405877563/htdocs/wordpress/wp-content/plugins/wp-photo-album-plus/wppa-admin.php on line 36 and defined in /homepages/39/d405877563/htdocs/wordpress/wp-includes/wp-db.php on line 990
    
    Warning: Missing argument 2 for wpdb::prepare(), called in /homepages/39/d405877563/htdocs/wordpress/wp-content/plugins/wp-photo-album-plus/wppa-admin.php on line 40 and defined in /homepages/39/d405877563/htdocs/wordpress/wp-includes/wp-db.php on line 9

    I'm guessing it is a compatibility error with a plug in?

    Anyone able to help? Looks like other posts are flagging similar issues

  3. KatyTowsey
    Member
    Posted 2 years ago #

    I got
    Fatal error: Call to undefined function get_taxonomies_for_attachments() in D:\hosting\10106030\html\wp-admin\menu.php on line 67

    any help please?

  4. emilyandtylercullen
    Member
    Posted 2 years ago #

    I just downloaded it & my blog is messed up!! It's all "Add Media" and will not let me toggle to text! I am trying to post today for Hurricane Sandy relief because of the benefit concert and it is really important to get this post up TODAY! Please help!

  5. louiepsp
    Member
    Posted 2 years ago #

    Well, solved for me at least. WP3.5 with BuddyPress 1.6.1.
    After deleting the plugin "BP Gallery Plus" I no longer get errors thrown with the plugin "Buddypress media".

    Everything else seems to be stable for me.

    Hope that helps someone.

  6. These prepare errors are caused by broken plugins or themes. Please contact those plugin or theme authors and tell them to read this post:

    http://make.wordpress.org/core/2012/12/12/php-warning-missing-argument-2-for-wpdb-prepare/

    In the meantime, disable that plugin or use a different theme.

  7. mairaj
    Member
    Posted 2 years ago #

    Contact your plugin/theme author for an update. Use the following temporary solution until update.

    ini_set( 'display_errors', false );
    error_reporting( 0 );

    Just add the above in the theme's function.php before the closing of the file ie; before ?>

    regards

  8. mikeday1uk
    Member
    Posted 2 years ago #

    I resolved mine - it just needed a plugin to be updated - look at the error message after the words wp-content/plugins and it will tell you which plug in needs updating or is causing the issue

Topic Closed

This topic has been closed to new replies.

About this Topic