[resolved] 3.5 Update Failed! Info + Pic. (7 posts)

  1. JustCharlie
    Posted 2 years ago #

    I upgraded to 3.5 today and the upgrade failed! I know why it failed as well: my host disabled index.php so it was not writeable.

    But here am I now, unable to even open wp-admin. This is the last thing I saw: screenshot

    How can I get this working? I downloaded WP 3.5 locally and can replace whatever files are need via FTP.

    Thanks in advance for your help!


  2. keesiemeijer
    Posted 2 years ago #

  3. adias00
    Posted 2 years ago #

    what host are you using it could be your ?

  4. JustCharlie
    Posted 2 years ago #

    Try doing a manual upgrade:

    I will give that a shot, thanks very much!

    what host are you using it could be your ?


  5. JustCharlie
    Posted 2 years ago #

    Unfortunately this didn't work.. I manually updated wp-includes and wp-admin but it still shows the same error:

    Fatal error: Call to a member function register_handler() on a non-object in /home/nibiru/public_html/tap4fun.com/wp-includes/media.php on line 944

    Anything else I should try?

  6. darkan9el
    Posted 2 years ago #

    I had a similar issue, sounds like you only did a partial update.

    I unzipped the 3.5 update zip file, selected all the files in the 3.5 update wordpress folder; this unzipped as "WordPress 2" because I already had a WordPress folder.

    I used Filezilla FTP to open my site and dragged all the files over to my root folder; the one where you see:

    • ..
    • blogs
    • tmp
    • wp-admin
    • wpcontent

    etc etc...

    waited until it all copied over, waited another 10 mins to let anything finish then typed my address and boom it all came back up.

    The only issue I now have is the pale yellow notification bar at the top telling me I had a failed update "please attempt the update again now" how do I remove it as I'm on 3.5 and everything is running fine.

  7. JustCharlie
    Posted 2 years ago #

    I ended up following the advice in this thread and it worked! Thanks everyone for your suggestions.

Topic Closed

This topic has been closed to new replies.

About this Topic