WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 3.5 Media and Editor woes

[Resolved] 3.5 Media and Editor woes

  • Since the upgrade we have the following two problems

    1. Clicking on the Visual tab in the editor has no effect, only nText is available

    2. Having added images to the media gallery, clicking the Insert Into Post button returns to the editor, but does not insert anything into the post.

    We’ve tried on IE9 and Chrome24 and the behaviour is the same on both. Using the default theme.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Tara
    Volunteer Moderator

    @t-p

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    -Also, review this 3.5 troubleshooting post: http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    Thanks.
    I’ve tried all your suggestions and none made any difference.
    I can’t see anything relevant in the troubleshooting post.
    Any more ideas?

    kmessinger
    Forum Moderator

    @kmessinger

    So you did turn off all plugins and switch to the default theme?

    I can’t see anything relevant in the troubleshooting post.

    How about using your browser to find javascript errors? Did you try reinstalling wp?

    Yes, as I said I switched off all plugins – no difference – switched to default theme – no difference – also reset the plugins folder – no difference.
    I already have jscript debugging turned on, and don’t get anything.

    How can I reinstall wp without losing anything? Is it genuinely likely that this will fix the issue? There seem to be a lot of other people reporting similar things, surely they can’t all have a corrupt installation?

    kmessinger
    Forum Moderator

    @kmessinger

    Add define( 'CONCATENATE_SCRIPTS', false ); to the wp-config.php file.

    Yes, you can reinstall and you should not loose anything by following this guide – http://codex.wordpress.org/Updating_WordPress#Manual_Update

    The upgrade process will affect all files and folders included in the main WordPress installation. This includes all the core files used to run WordPress, two plugins (Akismet and Hello Dolly) and two themes (Twenty Twelve and Twenty Eleven). If you have made any modifications to those files, your changes will be lost.

    Foolishly I reinstalled first – which made no difference.

    I then spotted your first suggestion to add the line to wp-config, and that seems to have solved the problem 🙂

    Can you tell me what this does and why it worked?

    Thanks!

    kmessinger
    Forum Moderator

    @kmessinger

    If left alone your existing javascripts are combined into strings that run faster. There can be too many strings or some other problem in the process. By setting false you are turning that feature off and getting rid of the problem. This is how I think it works
    but I don’t know much about it.

    I am glad it worked for you.

    And please if someone has a explanation of Concatenate fire away!

    define( ‘CONCATENATE_SCRIPTS’, false );

    where did u add it to work?

    i have similiar issues except that when i click on the “add media” button. nothing happens.

    when i deactivate my theme, problem goes away.

    plugins are not the problem.

    SCRIPT_DEBUG
    did not fix the problem!

    javascript errors are:

    Uncaught SyntaxError: Unexpected token < quicktag.js:1

    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.trottyzone.com/wp-admin/images/wpspin_dark.gif

    Uncaught TypeError: Object [object Object] has no method ‘on’ media-models.js:904

    Uncaught TypeError: Object [object Object] has no method ‘on’ common.js:167

    WPyogi
    Forum Moderator

    @wpyogi

    @clickmac – please do not post in multiple places — it does not get you faster or better help and interferes with other people’s threads.

    Thanks, I’ll mark this as resolved

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] 3.5 Media and Editor woes’ is closed to new replies.