Support » Fixing WordPress » 3.5 issues: no toolbar, media uploader not working, can use text only

  • Since automatic updates to 3.5 I have the following problems:

    • visual editor is not working – can write in text only and there is no toolbar
    • the media uploader does not insert images into posts

    I have read other troubleshooting advice and tried the following:

    • disabling plugins
    • switching to twentytwelve theme
    • downloading a fresh version of 3.5 and manually reinstalling all folders other than wp-content
    • adding the line of code as follows to end of wp-config.php file:
      define(‘CONCATENATE_SCRIPTS’, false ); and re-uploading the file

    I use the Weaver II Pro theme for all my sites.

    Nothing has fixed the problem with WordPress 3.5. Now I have six different sites to which I can upload only text.

    Although I can use FTP and find my way around Hostgator’s CPanel, I am not a techie and generally, I can’t fix problems with code, although I did manage to add the recommended line of code to the wp-config.php file.

    I guess what I want to know is (since I can’t roll back my sites to the previous version without re-posting everything): will there be an updated version of 3.5 SOON that can fix all these problems with an automatic update?

    Here’s the site where I first had the problem… but I’ve checked a couple of my other sites and have exactly the same issues.


Viewing 15 replies - 1 through 15 (of 20 total)
  • I have the same issue here

    Same here, I tried addons on/off, adding the define(‘CONCATENATE_SCRIPTS’, false ); and the script debug one, all to new effect.
    Tried switching to new themes/update cache, nothing works. I’m having this problem on 3 on my 6 sites, very weird. One site I’m having the problem with was a brand new site without even any plugins or themes installed … All sites are on the same vps server as well … not work not work (Brand new site) works ! works

    and so on ….

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator not work not work (Brand new site)

    What does the javascript console on your browser say for the sites that are not working and how far did you get with this list?

    Same issue. Visual no longer selectable. WPPA+ (Photo Albums Plus) also not working correctly. Can’t show hyperlinks and instead just shows the hyperlink command text.

    when I click on the visual editor tab I get this error :
    “Uncaught TypeError: Cannot read property ‘canvas’ of undefined”

    I did try every thing on that list. And like I said the site sharingfilestoday, was a brand new domain I just bought, fresh new install with no plugins or themes installed except default theme. first thing I did was try to post, and visual editor not working, and hasen’t work since. I tried installing visual editor plugins since and nothing works. I mean fresh domain with new fresh wordpress install cancel’s almost anything that the page you mentioned tries to remedy.

    I tried with every browser as well, chrome, safari, firefox, IE, Opera

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Can you share the list of your Apache modules?

    If you make a <?php phpinfo() ?> file it should list them out under the apache2handler section.

    OK: I have a breakthrough.

    I cleared the cache on my Firefox browser and waited a while, then tried my WordPress site again.

    Hooray! My visual editor was back and I was able to upload a photo.

    Tried one of my other sites – still not working. So I manually uploaded all files from the fresh version of 3.5 (downloaded from the site) EXCEPT for wp-content, flushed Firefox cache, closed the browser, opened the site and signed in – and same result: everything is now working.

    I’ll do the same for my other WP sites.


    Handlers :
    “core mod_authn_file mod_authn_default mod_authz_host mod_authz_groupfile mod_authz_user mod_authz_default mod_auth_basic mod_cache mod_include mod_filter mod_log_config mod_logio mod_env mod_expires mod_headers mod_unique_id mod_setenvif mod_version mod_proxy mod_proxy_connect mod_proxy_ftp mod_proxy_http mod_proxy_scgi mod_proxy_ajp mod_proxy_balancer mod_ssl prefork http_core mod_mime mod_status mod_autoindex mod_asis mod_info mod_suexec mod_cgi mod_negotiation mod_dir mod_actions mod_userdir mod_alias mod_rewrite mod_so mod_bwlimited mod_php5 mod_security2”

    I will try reuploading files manually when I get back, see if that does anything

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    I cleared the cache on my Firefox browser and waited a while, then tried my WordPress site again.

    Hooray! My visual editor was back and I was able to upload a photo.


    That’s… weird but good news. Especially since you’re the original poster and bluntman001 and I have gone all over the place. I apologize for that, we should have been focusing on your issue and no one else’s.

    If you can, please test your WordPress site in another browser after you’ve cleared your cache and wiped your cookies. This is just a sanity check to make sure your problem is resolved and not a fluke.

    Bluntman001, could you do me a favor and start your own topic? Yours is different from Marg’s and here we need to focus on her problem. We can pick up your problem on your own thread.

    How-To and Troubleshooting

    Yea really sorry for taking over your thread, I did not mean to do this and I have started my own thread @

    No worries. It’s difficult when the same problem shows up, and from Googling this topic I can see that it’s widespread.

    I just flushed cache/deleted cookies in both Chrome and Explorer and tried the sites, and THEY ALL WORK. (The original problem was also showing up in other browsers, by the way.)

    I can only put it down to reinstalling the files over the existing ones (by the way, I didn’t delete the old folders, either… just replaced them: all but wp-content) and then flushing the cache, since nothing else I did had any effect. (Unless Hostgator has somehow fixed the problem on a server-wide basis, of course.)

    Whatever the reason it’s working, I’m breathing a big sigh of relief.


    Hi there – I am having the same problem. I can only see TEXT editor when editing a new post and nothing happens when I press the Add Media button. I have deactivated all plug ins and managed to see new media upload screen, but after clicking upload to post, nothing happens. I reverted to TwentyEleven theme but that didn’t solve anything so think my theme is fine (Genesis, Pretty Young Thing). I’ve since re-activated plug ins and my theme and problems persist. Is anyone able to take a look and spot the problem? I am really non techy and worry that I will do more harm than good if I try and fix this myself! My site is

    Many thanks, Wendy

    I had the exact same problem as margmac and I was able to fix it by uploading the WP 3.5 files manually and clearing the browser cache. Thank you margmac for the help!

    I see the similarity in our issue is we both host via Hostgator and have automatic updates enabled. So this could be a Hostgator issue. I have a friend who is hosted with Hostmonster and upgraded to WP 3.5 from within Admin and she doesn’t have these problems.

    So now…. I have to upload new files to all my client’s account. Bummer.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘3.5 issues: no toolbar, media uploader not working, can use text only’ is closed to new replies.