Support » Fixing WordPress » 3.5 has broken my "Add Media" button

  • Resolved westonadam


    Version 3.5 has broken my “Add Media” button. It almost never works. Frustratingly, it works very, very infrequently.

    I have disabled all plugins. I have done a fresh automatic reinstallation of 3.5. I have cleared my browser cache, disabled all browser add-ons, and tried both Firefox and Chrome. Nothing helps.

    Thank you for your help.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Also, yes, I am using the Twenty Eleven theme. No, I desperately do NOT want to do a manual reinstallation of all of WordPress.

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

    Forgive me, but wp-config.php does not appear as a file in Appearance–> Editor. Should I be looking somewhere else?

    Yes. The file is in your root WordPress folder, so you will need to access it using FTP or whatever file management application your host provides. Remember to only use a plain text editor when editing the file.

    Oh god. I hate doing this. I always feel like I run the risk of crashing the whole internet.

    Yep. I broke it. I cut and paste what you had written on a new line. Now I get this on my site (

    Parse error: syntax error, unexpected T_REQUIRE_ONCE in /home/adamnorman/ on line 37

    Any idea what I did wrong? The last four lines of wp-config.php look like this:

    // Get everything else
    define(‘CONCATENATE_SCRIPTS’, false )

    Add ; after define('CONCATENATE_SCRIPTS', false )

    Right. That seems to have fixed the small problem (breaking the internet) and the problem that brought me here (Add Media).

    Thank you, thank you, thank you.

    If you have time, could you explain, briefly, what I did? I’d like to know how you fixed what you fixed.

    Thanks again.

    You instructed WordPress to use individualised versions of its core javascripts. In order to try and maximise site performance, WordPress concatenates (joins) the javascripts together into a single download but some servers can experience problems with such concatenated scripts.

    Thanks, esmi. You’re great.

    No problem. Glad I could help 🙂

    This concatenate scripts issue does not seem to work for me. I have done some testing, and it seems to be narrowing down to a database issue. Not sure why though. I did a fresh install of wp and it worked fine. I activated all plugins and it worked fine. I started to import database records and it seems fine until I add usermeta records and then it breaks

    Not sure why WP aren’t rushing out a fix on this

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘3.5 has broken my "Add Media" button’ is closed to new replies.