WordPress.org

Support

Support » How-To and Troubleshooting » 3.5 causing SOME pages to be blank and uneditable

3.5 causing SOME pages to be blank and uneditable

  • I’ve been reading about some of the other issues people are having with the 3.5 upgrade and it causing their post/page editing space to be blank. The website itself seems to be working fine and all the pages are visible (thank God!) but I’m having the same “blank page” issue but only on SOME of my pages.

    Most pages appear to come right up and I can edit them just fine, while other pages do not. I don’t see any rhyme or reason as the pages are all laid out exactly the same (with simple HTML).

    I read that the Bulletproof Security plug in was causing the problem, but I don’t have that.

    I then read to do the SCRIPT_DEBUG step. I did that but it had no effect.

    I went through and disabled my plugins one by one (I don’t have that many) and to no avail.

    Any other ideas? Is a WordPress Update in the works for this???

Viewing 15 replies - 1 through 15 (of 28 total)
  • Can you check your server’s PHP error log to see if it’s reporting any issues?

    Thanks for the help George. The 2 most recent logged errors are:

    [11-Dec-2012 19:53:12] WordPress database error Duplicate key name ‘type_status_date’ for query ALTER TABLE wp_posts ADD KEY type_status_date (post_type,post_status,post_date,ID) made by wp_upgrade, make_db_current_silent, dbDelta, W3_Db->query

    [12-Dec-2012 10:47:06] PHP Warning: Missing argument 2 for wpdb::prepare(), called in /home/xxxxxxxx/public_html/wp-content/plugins/search-regex/searches/post_content.php on line 10 and defined in /home/xxxxxxxx/public_html/wp-includes/wp-db.php on line 990

    The error for December 11 I will need help interpreting. Any idea what it means?

    The error for December 12 looks like it’s related to a plugin I have called “Search Regex” so I have disabled/deleted it, but the problem still remains.

    The interesting thing is that it appears that only ONE of my pages is affected (the editing screen is empty). I can see the page title and the “Visual” and “Text” tabs but clicking on them does nothing and the editing field is completely blank.

    Can you turn on WP_DEBUG and see if you get more error messages?

    Have you deactivated ALL, yes I said ALL, of your plugins… refreshed your browser cache.. and tried again?

    I googled how to setup WP_DEBUG in my wp-config file so I tried that but I didn’t get any errors.

    Josh, no I haven’t deactivated ALL of my plugins, but I did most of them. I would assume that the ones that everyone uses (Askimet, All in One SEO, for example) would be safe otherwise there would be a LOT more problems being reported here. But just to be thorough I’ll try ALL of them and report back.

    Cool. Also remember to manually empty and refresh your browser cache after deactivating all the plugins.

    Errors on Dashboard

    Notice: register_setting was called with an argument that is deprecated since version 3.5! The “privacy” options group has been removed. Use another settings group. in /home/blogdumc/public_html/wp-includes/functions.php on line 2908

    Notice: add_settings_field was called with an argument that is deprecated since version 3.5! The privacy options group has been removed. Use another settings group.

    After adding DEBUG True, I can see these on dashboard.

    Please help, I am not able to add media or links ?

    @ shasha7,

    It’s one of your plugins trying to register settings using a deprecated method.

    You’ll need to start deactivating them and watching for when the notice goes away. Eventually, you will find one plugin which is causing these warnings.

    Thanks Josh, Let me check.

    Thanks a lot Josh, my problem is solved but The plugin which caused this error Why can’t i use it again.Please advise ?

    What plugin was it?

    Contact the plugin author and developer. See if they are aware of the issue. Be tactful… as they may already know and be working on a fix.

    What plugin was it?

    @ josh – Yes, I visited his page and glad to see the message they are working on 3.5 ?

    @ george – chrisguitarguy / WP-Robots-Txt, Wp-Socializer and Facebook Promote box

    Aye ya ya… three?? Bam!! Kick it up a notch 😉

    I am facing these issues for the first time but its really hard time for all users and developers after a new WordPress update?

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘3.5 causing SOME pages to be blank and uneditable’ is closed to new replies.