Support » Fixing WordPress » 3.5 "An error occurred in the upload. Please try again later."

  • Resolved rockdio


    Recently upgraded to 3.5.1
    I know it has been asked before, but after 3 days reading here and in google no solution so far for this error.

    I am using a twentyeleven child, which i upgraded to twentytwelve child.

    If i use twentytwelve the image upload works.
    There is no JS errors on the console.

    I have tried:

    *Turning on Debug
    *Disabled all plugins
    *Deleted all plugins
    *Reinstalled wordpress
    *Installed wordpress in another domain from scratch
    *left only the child theme from wp-content
    *Read trough all the Master list
    *All the crazy solutions in several posts (deleting plugins from tinymce, adding lines to wp-config.php jumping on my wooden leg while sacrificing a parrot [this is from my pirate forum])

    Finally I found a solution, and it is very simple.
    Now the image uploader works with twentyeleven, twentytwelve and my child.

    I am making you read all this because of the time i spent finding the solution.

    Which I am posting on my site. Not here

    Because none of the moderators, or contributors here thought of giving actual help and kept asking users to RTFM, to try the default troubleshooting whatyamacallit, or disabling plugins. Or even worse… Asking the user to create a new question when he was asking the same question with the same problem which went unanswered since the roll down of 3.5

    Worse i suffer for all the poor souls that had to start a new child theme from twentytwelve when they had a perfectly working thing on 3.4 and all the time they spent on it.

    This post will be probably moderated because of this, but in case they are nice enought to keep this post here is the link ot the answer.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thank you so much for posting, rockdio! While it doesn’t solve the problem, it at least gives me a solid lead on fixing it.

    Btw your is probably the fifth or sixth post on this topic that I had to look through to find something approximating a solution. NONE of them are linked together to give a better chance on figuring out what the problem is.

    As per the Forum Welcome, please post your own topic. Your problem – despite any similarity in symptoms – is likely to be completely different.

    Imagine a doctor discovering dozens of people showing the same set of symptoms, but concluding it couldn’t possibly be the same disease!

    Here are some of the other posts on ‘unrelated’ problems:

    You are right mate, my solution is based on the consolidation of all the leads i found scattered around at the time i had the problem and that is more or less the reason i posted it in my blog, so I could concentrate all the feedback and different symptoms in one place instead of scavenging the internet for bits of information, and update the troubleshooting if something new came up.

    So far all points to JS implementations from the feedback i get in my blog.

    Glad it helped



    i agree, but dont really blaim moderator, they have rules to follow; they copy and paste that text whenever someone does not explain the issue.

    lets try to solve this.

    i have been having exactly the same problem lately.
    – Every time i upload an image with “Set fetarure image” i get the error message: “An error occurred in the upload. Please try again later.”
    – if i upload an image directly in the Media Library, stays in “crunching” status.

    I have tried:
    – reinstalling wordpress thousands of times
    – changing the hosting
    – changing the hosting permissions
    – changing the wp-config file
    – changing the .htaccess file
    – activating and reactivating mod rewrite
    – changing permalinks
    – deactivating all plugins
    – not installing plugins at all after reinstalling wordpress
    – changing themes to Twentytwelve to my custom themes and viceversa.

    After one week traying everything i isolated the problem to my theme, so it is in my theme; it has to be because when i change to TwentyTwelve, for example, it works, but when i change back to my custom theme, stops working.

    if i find why this happens, i will come back, and post it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘3.5 "An error occurred in the upload. Please try again later."’ is closed to new replies.