3.4.2 Database Update Issue (14 posts)

  1. cziiki
    Posted 3 years ago #

    So i recently took to upgrading our site to 3.4.2, at first through the automatic tool and then later by manual updating it.

    Why automatic and then manual, well upon updating the site works fine but everytime i try to access the wp-admin/ sub-page I'm greeted with:

    Database Update Required

    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.

    The update process may take a little while, so please be patient.

    To which I click the "Update WordPress Database" which leads to a blank page with a WordPress logo and blank box. And despite manual and automatic updates to the wordpress files, this page still remains.

    Any ideas as to how to fix this?

  2. WPProHelp
    Posted 3 years ago #

    First try by clearing the cache (including cookies) from your browser and try to access the page again.

    If you still have problems let us as there are many other solutions to this but this is the easiest one and is most likely to work.

  3. jeffpurcell
    Posted 3 years ago #

    I had the same issue. What I did to remedy the problem was to increase the amount of memory that PHP is allowed to have.

    I added
    just inside the opening PHP tag in wp-admin/upgrade.php

    Once the upgrade was finished, I removed that line.

    Please note your web host may not allow 256M. You may need to adjust that value to what they will allow.

    If that doesn't work, you can set WP_DEBUG to true temporarily in wp-config.php (It's usually located around line 81.) That should at least output a php error so we can help you troubleshoot from there.

  4. StanTheRebel
    Posted 3 years ago #

    I am having this same problem!

    I have been trying everything I can think of. I have tried deleting the upgrade.php file which results in a 'page not found' error. I have increased my php limit from 20 to 90, I have cleared my cache and such, different browsers, I have tried waiting. Nothing seems to be working. Are there any more solutions?

  5. StanTheRebel
    Posted 3 years ago #

    Ok so I tried what jeffpurecell suggested and that did not work either. I set my php.ini file to have a memory limit of 99M (the max that media temple will allow) and also set wordpress to debug mode. No errors :(

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    @StanTheRebel: Please post your own topic.

  7. StanTheRebel
    Posted 3 years ago #

    @Mod Sure thing

  8. drhamr
    Posted 3 years ago #

    @jeffpurcell: thanks for posting, your solution worked for me

  9. kwcg
    Posted 3 years ago #


    I have just resolved the update "loop" problem; I'm running WordPress on a virtualized Linux server, with Apache Web Service, PHP and MySQL.

    Thanks to jeffpurcell for the hints... After verifying that my server component services were up to snuff, turning on debug, and increasing the PHP memory space in /wp-admin/admin.php .... still no help... so I consulted with the most excellent tech support folks at Rackspace, (my hosting service), who quickly diagnosed the issue:

    On my server, the WordPress update was asking for ~36MB of memory, but:

    Regardless of the admin.php 'memory_limit' setting, Linux imposes a

      default session memory limit on PHP of 32MB

    If you've tried the memory limit increase in wp-admin/upgrade.php to no avail - you need to go "outside" the PHP box to your server's PHP service settings...

    I suggest you contact your hosting service to make the following changes, however; if you do have shell/root access to your Linux server, you can increase the PHP session memory limit temporarily by editing the vhost.conf for your domain.

    Once you have successfully updated WordPress, make sure to restore the php_admin_value memory_limit to default settings - otherwise your server will quickly run out of memory!

    Keep in mind, this example is for a virtualized Linux server, with WordPress running in a subdomain of the virtualized domain-name.com ... so change the paths to suit your own setup:

    Edit the file:

    Put this in it:
    <Directory /var/www/vhosts/domain-name.com/subdomains/blog/httpdocs>
    php_admin_value memory_limit 128M

    Run the following command via SSH:
    /usr/local/psa/admin/bin/websrvmng -av

    Run the upgrade, and then remove what you added to the vhost.conf file. After removing the file, run the above command again:

    /usr/local/psa/admin/bin/websrvmng -av

    I have now successfully updated WordPress - and all is (seemingly) well. With DEBUG turned ON I am seeing a slew of notices regarding various plugins - another post topic.

    Hope this helps!

    Key West Computer Guy

  10. dporchia
    Posted 3 years ago #

    Thanks @jeffpurcell...your solution worked. Had to bump it up to 512MB though.

  11. Chad Warner
    Posted 2 years ago #

    @jeffpurcell: Thanks, it worked for me!

  12. DLThompson06
    Posted 2 years ago #

    Thank you jeffpurcell! I've been dealing with the situation for several days. Your solution worked. Not sure if it makes any difference, but for those who aren't having any luck, I made sure the upgrade.php file permissions were set to 644 before giving it a try.


  13. jeffpurcell
    Posted 2 years ago #

    I should have included in my original post that once the update is complete you need to remove the memory limit increase and set WP_DEBUG back to false.

  14. WPyogi
    Forum Moderator
    Posted 2 years ago #

    This thread is titled for updating 3.4.2 - is that what you people are doing? If not, please start a new thread per


    Otherwise, it causes much confusion for people.

Topic Closed

This topic has been closed to new replies.

About this Topic