Support » Fixing WordPress » 3.4 upgrade- Fatal error

  • Resolved horseart

    (@horseart)


    I’m not an advanced techie.

    After upgrading to 3.4 I get a fatal error.

    I checked for spacing before and after </php>
    I read how to delete dbcache. I couldn’t find it in my FTP blog folders.
    I renamed theme to old. When that didn’t work I deleted it.
    …wondering if I made things worse.

    Still getting
    white page with Fatal error: Call to undefined function wp() in /home/lisasart/public_html/blog/wp-blog-header.php on line 14

    sorry if there was an answer to this some where. I’m tiring to stay focused and find the answer yet getting confused and uncertain.

    Thanks
    Lisa G.

Viewing 15 replies - 1 through 15 (of 26 total)
  • Manually upload all the WordPRess files using FTP. That should do it. 🙂

    OK, I sat down and gave it a shot.

    I can see my site now sort of normal, except when I go to an individual post I notice the top part of dash bar appears like when I’m logged in.

    I can’t login though or do anything as I would. Warning, fatal error

    Warning: require_once(/home/lisasart/public_html/blog/wp-admin/includes/upgrade.php) [function.require-once]: failed to open stream: No such file or directory in /home/lisasart/public_html/blog/wp-admin/upgrade.php on line 21

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/lisasart/public_html/blog/wp-admin/includes/upgrade.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/lisasart/public_html/blog/wp-admin/upgrade.php on line 21

    I checked my cpanel and in wp-options the url is correct in both wp1, wp2.

    url: http://www.lisasart.com/blog

    sigh
    thanks

    Lisa G.

    @lisa G,
    I do not find any problem as you describe. Your blog is loading perfectly and fast without any problems.

    The Problem is: I can’t login to do anything with the blog.

    I get a white page with this:

    Warning: require_once(/home/lisasart/public_html/blog/wp-admin/includes/upgrade.php) [function.require-once]: failed to open stream: No such file or directory in /home/lisasart/public_html/blog/wp-admin/upgrade.php on line 21

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/lisasart/public_html/blog/wp-admin/includes/upgrade.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/lisasart/public_html/blog/wp-admin/upgrade.php on line 21

    any suggestions and help would be appreciated.

    Thank you
    Lisa G.

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of your current version of WordPress.

    I’ve tried those and still getting Warning- Fatal error messages:
    mentions Line 21 in upgrade.php

    Looking over file, do you happen to see an error in this file.
    I delete spaces in Line 21, but it didn’t seem to help.

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    Thanks
    Lisa G.

    Is your problem solved? If not TRY TO LOGIN HERE

    It’s not resolved.

    I tried the login link. This is the error I continue to get.

    Warning: require_once(/home/lisasart/public_html/blog/wp-admin/includes/upgrade.php) [function.require-once]: failed to open stream: No such file or directory in /home/lisasart/public_html/blog/wp-admin/upgrade.php on line 21

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/lisasart/public_html/blog/wp-admin/includes/upgrade.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/lisasart/public_html/blog/wp-admin/upgrade.php on line 21

    I checked Line 21- require_once() [function.require]:
    and deleted spaces.

    I still can not login.

    Lisa G.

    Try re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    I tried it. Still not working.

    Lisa G.

    I am not 100% sure, but it seems to me that the upgrade.php file is either missing or the permissions are not set correctly.

    You should be able to hit this link, http://www.lisasart.com/blog/wp-admin/install.php, and it will tell you that WP is already installed. Instead, it’s giving an error related to a call for the upgrade.php file.

    i install it but get erorr …
    see here..
    missed page template in wp panel ver 3.4 farsi

    I adjusted the Line 21, then other error lines.
    I was able to get to Update Database, but get- Database Update Required, Update Complete over and over.

    don’t know if I solved anything. sigh. perhaps.

    Still can Not login and do anything. sigh

    Lisa G.

    I checked out this site for a solution.

    Solution for WordPress WP-Options Issue – Database Upgrade Required

    Yet when I go into my phpadmin and go to wp_options I don’t see db_version
    thing as he shows.
    I see site url, which I changed back again.
    I’m not a techie and am sort of confused.

    Still not working. sigh

    Lisa G.

    You may need to go to a second page in the wp_options table to find db_version.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘3.4 upgrade- Fatal error’ is closed to new replies.