Support » Fixing WordPress » 3.3.1 Upgrade "you do not have permissions to access this page"

  • Resolved JoeMeyer

    (@joemeyer)


    Hello everyone.

    I have upgraded to the most current version of WordPress on several sites. Only one currently has this problem (no other issues were realized during the other upgrades). Here is my situation:

    – Deactivated all plug-ins
    – Manually re-installed 3.3.1
    – Ensured DB version was current
    – Deactivated theme and tried to access, yet was still unsuccessful
    – In conclusion, it is not a theme, plug-in, or database issue.

    What else could be the problem?

    Any help would be appreciated.

    Blessings,

    [No bumping. If it’s that urgent, consider hiring someone.]

Viewing 15 replies - 16 through 30 (of 61 total)
  • If it’s at all helpful, whenever I try to log-in, the page that I am directed to that gives me the permissions error is:

    http://mydomain.com/wp-admin/profile.php

    I looked at this file in my content manager, but there was nothing that seemed I could edit or change.

    Any further ideas?

    Blessings,

    After reading some, it is possible that my .htaccess file could have an error in it? After looking at the file, I am not sure which line could be restricting me access.

    Thoughts?

    Blessings,

    esmi

    (@esmi)


    Forum Moderator


    Thanks for the contribution esmi, but I tried all of those techniques and still cannot access my dashboard. I double checked the DB prefixes and forced another DB upgrade. Furthermore, I deleted more plug-ins (in deeper file folders) and removed related files connected to them – apparently, to no avail.

    Any other thoughts? I feel like I’m the only guy with this particular issue!

    Blessings,

    esmi

    (@esmi)


    Forum Moderator


    Have you tried:

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by PhpMyAdmin.

    What db_version number is in the wp_options table?

    Hey there.

    Yes, I’ve tried to switch themes. I currently run the theme on two websites, both are on 3.3.1 and only the one is question is having problems. I contacted the developer and he said he knew of no issues regarding permissions.

    I deleted every plug-in on the website, except one, of which I know there are no issues with

    The DB number is: 19470

    Blessings,

    esmi

    (@esmi)


    Forum Moderator


    Have you tried manually editing the db-version value to 18226 to force an upgrade? Obviously, do backup your database before trying this.

    I’d also try the plugin reset, if I was in your shoes.

    I haven’t tried to that specific number, but I have done a force DB upgrade two times.

    Define plug-in reset?

    Blessings,

    esmi

    (@esmi)


    Forum Moderator


    See this Codex section. Use the Phpmyadmin method.

    After renaming the plug-in folder to “plugins.hold”, I still cannot access the dashboard.

    Thoughts?

    Blessings,

    I even tried using the number, ‘18226’ to force the DB version change. After it updated to its proper number, I still do not possess proper permissions.

    Thoughts?

    esmi

    (@esmi)


    Forum Moderator


    Is there anything in your site’s error logs that might give a clue?

    How could I check the error log?

    esmi

    (@esmi)


    Forum Moderator


    You’d need to ask your hosts if/how you can access them.

    Thanks!

Viewing 15 replies - 16 through 30 (of 61 total)
  • The topic ‘3.3.1 Upgrade "you do not have permissions to access this page"’ is closed to new replies.