Support » Fixing WordPress » 3.3.1 Upgrade "you do not have permissions to access this page"

  • Resolved JoeMeyer

    (@joemeyer)


    Hello everyone.

    I have upgraded to the most current version of WordPress on several sites. Only one currently has this problem (no other issues were realized during the other upgrades). Here is my situation:

    – Deactivated all plug-ins
    – Manually re-installed 3.3.1
    – Ensured DB version was current
    – Deactivated theme and tried to access, yet was still unsuccessful
    – In conclusion, it is not a theme, plug-in, or database issue.

    What else could be the problem?

    Any help would be appreciated.

    Blessings,

    [No bumping. If it’s that urgent, consider hiring someone.]

Viewing 15 replies - 1 through 15 (of 61 total)
  • Moderator kmessinger

    (@kmessinger)

    When does this error occur?

    When I try to log-in; sorry for not stating this.

    Blessings,

    PS: thanks for the correction – I won’t bump anymore.

    Moderator kmessinger

    (@kmessinger)

    This site is on a different server? Using ftp or logging into your host check the permissions on the wp directories.

    Manually re-installed 3.3.1

    So you had permission to do that. Hmmm. Have you tried wp-login rather than wp-admin?

    Hey there.

    Thanks for the comment.

    I got a 404 error. I typed, “mydomain.com/wp-login”.

    Is that what you were suggesting?

    Blessings,

    Moderator kmessinger

    (@kmessinger)

    Sorry, wp-login.php

    I get the same error, ‘You do not have sufficient permissions to access this page’.

    It refers to me to http://mydomain.com/wp-admin/profile.php, which is causing the permissions issue.

    Any ideas?

    Blessings,

    After deleting all my cookies, trying another internet connection, and removing every plug-in from the site (except one that I know isn’t causing the issue), I am still having this issue.

    Usually, either the THEME, a PLUG IN, or a DATABASE ISSUE is causing the problem. However, based on my research and information, the error plaguing me is still alive and festering.

    Any further ideas?

    Blessings,

    Moderator kmessinger

    (@kmessinger)

    What does the .htaccess file say?

    Check database wp_usermeta id – it should be 1

    Did you change the prefix of the tables in the db? If so check that all are the same (upper/lower case matters).

    This is my .htaccess:

    SetEnv PHP_VERSION 5
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Regarding the usermeta ID, if you’re referring “Cardinality”, it is indeed 1; and my capabilities are:

    a:1:{s:13:"administrator";s:1:"1";}.

    I did change the prefixes, and they are all the same.

    Is this helpful?

    Blessings,

    Moderator kmessinger

    (@kmessinger)

    Try setting it to this

    a:1:{s:13:"administrator";b:1;}

    hello sir!

    I’m having the same problem. I did the solution posted above:

    a:1:{s:13:”administrator”;b:1;}

    but it still won’t work. Whenever I try to log in I get this error message.

    You do not have sufficient permissions to access this page

    I don’t know what the problem is. It’s a fresh install with the multisite enabled. No plugins or themes activated yet.

    Hello there.

    Even after the new database user change, I still receive:

    You do not have sufficient permissions to access this page.

    Any other ideas?

    Blessings,

    I’m maintaining two wordpress websites as well. So far, the only site experiencing problems is the one which is multisite enabled. Mr. Meyer, is your website multisite enabled too?

    Moderator kmessinger

    (@kmessinger)

    Hey there.

    I’ve only heard about multi-sites. What are they? I believe my website is NOT a multisite.

    Thanks Kmessinger for the link, but how is that helpful in my circumstance? I’m still unable to enter the dashboard area.

    Blessings,

Viewing 15 replies - 1 through 15 (of 61 total)
  • The topic ‘3.3.1 Upgrade "you do not have permissions to access this page"’ is closed to new replies.