Support » Fixing WordPress » 3.3 media upload problems

  • Media upload not longer working after upgrade to 3.3.

    I have seen a lot of post about this but nothing that has helped me.

    Here is the error I am getting
    Warning: copy(/home/barbsonm/public_html/wp-content/uploads/2012/01/logo.jpg) [function.copy]: failed to open stream: Permission denied in /home/barbsonm/public_html/wp-admin/includes/file.php on line 348
    606

    MY permissions for my upload folder is 755…

    Anyone have any ideas? I am pulling my hair out over here… And for some reason they keep CLOSING topics although the problem is NOT resolved…

Viewing 15 replies - 1 through 15 (of 19 total)
  • Why is it that no one can solve this problem???? I see people all over the place have it! Especially after the 3.3 upgrade. This is a major problem and needs to be fixed! I am on complete hold on turning this website over to the client until I can figure out how to fix this… I have already contacted my host and he said it was a wordpress problem….

    esmi

    (@esmi)

    Forum Moderator

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

    when I tried 766 I got this error.

    “A united logo.jpg” has failed to upload due to an error
    Unable to create directory /home/barbsonm/public_html/wp-content/uploads/2012/01. Is its parent directory writable by the server?

    I tried 767,775 and 777 and got this error

    Warning: copy(/home/barbsonm/public_html/wp-content/uploads/2012/01/AA.jpg) [function.copy]: failed to open stream: Permission denied in /home/barbsonm/public_html/wp-admin/includes/file.php on line 348

    Just so you know this is what file.php line 348 is
    “copy( $tmp_file, $new_file );”

    esmi

    (@esmi)

    Forum Moderator

    Ask your hosts to check if you have a folder ownership issue.

    Edit to create new thread, because it appears the issue is not exactly the same.

    Thanks esmi
    I asked my host that question, should have a response tomorrow.

    Sorry Scott… I am not exactly sure what you are saying…

    I looked through that Misskim but couldn’t find anything pertaining to my issue…

    I removed my original post and created a separate, different post. Because my issue wasn’t exactly the same as this posters issue. My issue has been resolved. My host had to modify my Fast CGI settings and increase the memory. Not sure if it was related to PHP being upgraded on my server and something not getting tweaked correctly, if 3.3.1 requires more memory, etc… but whatever it is, it is now fixed for me.

    ah ok thanks

    Did you resolve this in the end, Elithoomph?

    not exactly…

    I had my host move me to a new server and start from scratch, never really knew what caused the problem…

    I am getting this error for last 1 week and i tried to clean install and do everything and i ask the hosting services, they say permission is good. yet i am getting permission error on line 348. I m running latest version of WP. any one got it solved?

    Eliteoomph and Emaarkhan, seemz two months have passed since you face the problem, today I faced it, can you tell me how you got out of it (I am sure you did)…?!
    I’ve tried to change permissions to 777, for upload folder, deactivate all plugins, change theme to default theme, and even install a fresh copy of wordpress 3.3.2 they all didn’t work…
    What am I missing…?
    What is the solution…?
    I’m very disappointed…!

    I ended up having to switch to a different server…

    Chambo11… i was working for a client.they had really bad server setup. so after so much testing 775 worked for me. all thanks to ninja girl esmi

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘3.3 media upload problems’ is closed to new replies.