WordPress.org

Support

Support » How-To and Troubleshooting » 3.2.1 causing issues inserting images/media/etc

3.2.1 causing issues inserting images/media/etc

  • Just upgraded (both on WordPress and on GoDaddy) to 3.2.1

    The buttons for Upload/Insert either a) no longer work b) ask if I want to leave the page instead of having a popup. It’s very sporadic. Either way, unable to insert images from the gallery from within a post (visual editor).

    The last time I had this issue it was because my WordPress & GoDaddy versions of WordPress weren’t the same, but I’ve ruled out that problem. Any suggestions? It was working fine before the upgrade.

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    I’m having the same troubles. I’ve tried deactivating and reactiving plugins but whenever I go to upload a new media item, the show/hide button basically does nothing. So you see none of the details, and are also not able to add the media to a post by selecting it from the gallery. The window that pops up when trying to insert media from a gallery also gets stuck and will not close when clicking the “X”.

    Any help would be appreciated

    esmi

    @esmi

    Forum Moderator

    Please post a new topic.

    My friend was having the same issues and it was solved by updating her disqus plugin.. even though it may seem unrelated.. they may somehow be related in a very minor way through variable changes because of the update to 3.2, etc, etc… hope that helps someone! Make sure when you update to the new WP platform that you keep an eye on your plugins for updates as well.

    Happy blogging! ~Liz

    awkward_clam

    @awkward_clam

    Yeah I’m having the exact same issue as OP. Resetting to 2010 theme fixes- maybe some themes not fully compatible with newest WP upgrade?

    Hi there, I have just updated my sites to WP 3.2.1, I found several known issues:
    – Quick Edit won’t work
    – Insert Image does nothing
    – etc

    I have found the solution by adding this to my functions.php

    if (!is_admin()) {
    	wp_enqueue_script('jqueryTools', 'http://cdn.jquerytools.org/1.2.5/full/jquery.tools.min.js');
    }

    It seems that jQuery Tools overrides some functions in WordPress and it breaks some features in the admin area.

    Hope this fix helps somebody, it did for me.

    Hi there, i was facing the same problem, but i found a solution its work for me, might this will help.

    tested on wordpress version 3.1.1, 3.2.1

    Check upload folder using your ftp account, you will find there two files named (.htaccess and .htpasswd)

    just renamed both and check, hopefully your problem will resolved.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘3.2.1 causing issues inserting images/media/etc’ is closed to new replies.