Support » Networking WordPress » 3.2.1 Broke Adding of Sites on Multiple Sites – Anyone else??

  • Alright so, I manage 9 different wordpress sites for academic and business purposes. Recently we updated to 3.2.1 on all of our networks. I’ve tried three of these networks now, and I can’t add a new site to users.

    The way I’ve always added sites to users, is when they register on the site, I go to network admin -> sites -> add new -> and I copy their email from their registration information, I title the site for them, and I give it a URL and hit add.

    Up until 3.2.1, that worked. Since the update, every new site just comes up with “Error establish a database connection” and it happens across all our sites (several of which aren’t connected by the way).

    I’ve tried disabling all plugins, and that doesn’t help. I’ve tried reinstalling wordpress and That doesn’t help. Could I be missing something??

Viewing 4 replies - 1 through 4 (of 4 total)
  • Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Could be a bad plugin. did you disable the ones within mu-plugins?

    That db error basically means the blog did not have its new tables created.

    I have a similar issue with 3.2.1. Tonight I got the ‘error establishing a database connection’ upon editing wp-config to allow multisite on my host. I sent a message to my host about this and while I was waiting went ahead and tried to do the same thing on my home machine so the two would eventually be in sync. But when I finished the network install and went to log in, I got the 500 error.

    Andrea, after reading your post I went back to check and there are 11 tables in the wp database at my host and 17 on my machine here. I assume the extra six are because it crashed a little later in the process, but I don’t know that for sure.

    This is a new install and a new site, so there are no plugins in use yet.

    I am very interested in how to resolve vcantrell’s issue and will be following this topic.

    yeah so I spent All evening debugging this, and it turns out that it was a similar plugin, installed on the site level that was causing this problem. It was the plugin “WP Simple Survey”, and disabling it restored the ability to make sites for users 🙂

    While I’m on here with Andrea_r, since you seem pretty knowledgeable…

    ever since 3.2.1, if I have network enabled, I can’t add plugins at the site level anymore on my main site. Is that normal? I’ve always distinguished site plugins and network plugins, but now the only way I have to add a plugin to my main site, is to go to the network admin, plugins, and install it then network activate it from there. It doesn’t seem like it should be that way, but it’s that way on any site that has a network installed.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    @nat – try & keep all your issues in one thread. Helps us keep ’em straight that way. 😉

    @vcantrell – yes, that’s normal. because you install a plugin in the entire network, not just for one site.

    If you only want ti for one site do NOT network activate it. Just install it. don’t click the link. visit the sub blog. activate the plugin there.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘3.2.1 Broke Adding of Sites on Multiple Sites – Anyone else??’ is closed to new replies.