Support » Fixing WordPress » 3.2 Updated: "Cannot redeclare wp_timezone_supported()"

  • Resolved fakelvis

    (@fakelvis)


    Hi,

    I’ve just updated four sites to WordPress 3.2 and one has failed.

    The site stayed in maintenance mode after the update, so I deleted the .maintenance file in the root folder and now get the following error:

    Fatal error: Cannot redeclare wp_timezone_supported() (previously declared in /wp-includes/functions.php:4018) in /wp-includes/deprecated.php on line 2617

    Is anyone able to help?

    (Please note, all four of my sites are on the same server and this is the only one that failed. All sites meet the PHP and MySQL version requirements.)

Viewing 5 replies - 1 through 5 (of 5 total)
  • mattyrob

    (@mattyrob)

    @fakelvis,

    That seems to me like an incomplete upgrade. If you can access the admin menus to a manual reinstall at Dashboard->Updates and then click on the blue Re-Install Now button.

    Otherwise it’ll be a case of uploading the files manually via FTP software.

    Moderator Dion Hulse

    (@dd32)

    Lead Developer

    Indeed this sounds like a failed update. MattyRob’s suggestion of a manual update is the only way to fix this.

    You can find the instructions on how to update manually here: http://codex.wordpress.org/Updating_WordPress#Manual_Update

    fakelvis

    (@fakelvis)

    @mattyrob,

    Thanks for letting me know. I am unable to access anything from /wp-admin/ so will attempt a manual update using the guide here: http://codex.wordpress.org/Updating_WordPress#Manual_Update

    I’ll come back and post an update if this worked.

    fakelvis

    (@fakelvis)

    @mattyrob & @dion Hulse,

    It worked perfectly. Thank you very much for your help. It’s really appreciated.

    aaronhall

    (@aaronhall)

    Although re-uploading a fresh copy of WordPress fixed this problem, it keeps re-occuring. Every few days my sites display an errors like these:

    Fatal error: Cannot redeclare wp_timezone_supported() (previously declared in /home/adh1/public_html/lawstudent.tv/wp-includes/functions.php:3891) in /home/adh1/public_html/lawstudent.tv/wp-includes/deprecated.php on line 2617

    Fatal error: Call to undefined function require_wp_db() in /home/adh1/public_html/electronicdiscovery.info/wp-settings.php on line 75

    I keep re-uploading a fresh copy, the blog works properly for a few days, and then I get these errors again.

    Any suggestions?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘3.2 Updated: "Cannot redeclare wp_timezone_supported()"’ is closed to new replies.