WordPress.org

Forums

3.2 Broke Visual Editor (multiple sites) (11 posts)

  1. mileswilliams
    Member
    Posted 4 years ago #

    I have several wordpress sites that I updated to 3.2, at that time the visual editor tab on all 3 sites I installed 3.2 on stopped working.

    I have turned off all plugins... no change.
    I have turned to 2011 theme instead of my custom theme.. no change.
    I have run health check plugin and received an excellent rating for 3.2 and beyond.

    Here is a video of what it looks like:
    http://screencast.com/t/0uhXnx3VbPNA

    I'm at a loss, not sure what to do..

    Any help would be appreciated. Thank you!

  2. Clear your browser cache so as to refresh the javascript libraries from your site.

  3. mileswilliams
    Member
    Posted 4 years ago #

    Tried that, no avail.

  4. mileswilliams
    Member
    Posted 4 years ago #

    Another screencast of what happens... Absolutely nothing.

    Any suggestions?

    http://screencast.com/t/0X6C0Bql5ie

  5. Check if your PHP version has JSON installed.

  6. mileswilliams
    Member
    Posted 4 years ago #

    How do I do that Ipsentu?

  7. Make a PHPInfo Page and look for JSON :)

    http://codex.wordpress.org/User:Ipstenu/How_to_create_a_phpinfo()_page

    You'll see it as:

    json
    json support enabled
    json version 1.2.1

  8. mileswilliams
    Member
    Posted 4 years ago #

    here is my phpinfo.php

    I tried to look in there, not very technical, but it looks to be disabled, not sure what I would do now.

  9. Aaron Jorbin
    Member
    Posted 4 years ago #

    @milesWilliams - it looks like -disable-json was used when your version of PHP was compiled. I would encourage you to contact your host and ask them to recompile php without this flag

  10. longjorn
    Member
    Posted 4 years ago #

    I enabled json on a Plesk 9.5.4 on SUSE 10.3 with php 5.2.11-0.1 by adding just two files to the server, root access is required.

    Details here:

    wordpress 3.2 Edit Post visual editor not working json missing

  11. Some servers (cpanel) let you enable it for yourself. When in doubt, ask your host :)

Topic Closed

This topic has been closed to new replies.

About this Topic