3.1.4 to 3.2 and admin functions are not working (29 posts)

  1. notez
    Posted 5 years ago #

    Screen options wont open
    Widgets wont open or drag
    Can not add tags to post

    I've already tried:
    Deactivating all plugins

    I just want to go back to 3.1.4 and I do have a database bak file. Can someone help me?

  2. notez
    Posted 5 years ago #

    I should also mention

    MySQL Version:
    PHP Version:

    and I'm now understanding it wont work with my database so how can I go back to the stable version I was on?

  3. notez
    Posted 5 years ago #

    Internet Explorer will allow me to make changes! How weird is that. Just can't do it in Firefox/Chrome...

    Any thoughts..?

  4. shovenose
    Posted 5 years ago #

    You need PHP 5.2.4

  5. Curtis
    Posted 5 years ago #

    With the sites I am creating, accessing the header image within theme administration is not possible after upgrading, as any click-event fails to load the page. This has occurred on new installs of WP 3.2, and upgrade from WP 3.1.4 I have attempted this over multiple sites, and servers.

  6. notez
    Posted 5 years ago #

    Is there a link or easy to understand documentation on how a newbie can rollback to 3.1.4 from 3.2?

    @salsaFire - hopefully someone will post to help you and I both resolve our issues.

  7. davidmoulton
    Posted 5 years ago #

    I have the same issues as OP following 3.2 upgrade.
    Can't post tags, widgets won't open. Can't logout either.
    The + shaped cursor appears on mouse over on widgets but they won't drag.
    Clicking on the 'down' arrow on an active widget, leaves a flashing text cursor to the left of the arrow.
    PHP version 5.2.12 is newer than 5.2.4 so should be fine. (The "dots" separate major and minor versions upgrades.)
    The WP 3.2 'Health check' widget gave my site the 'thumbs up'.
    Anyone else having this problem? I am on Hostgator so I'm sure more than 2 of us have run into this.

  8. Tidosho
    Posted 5 years ago #

    I'm getting a similar issue on my blog http://www.tidelog.info. The Admin panel or anything to do with it fails to load and displays a white page. It works in IE but my page body overflows its margin. It was working fine before I updated but can't remember the version I was on last.

    I'm running Firefox 5. It isn't PHP it's the browser.

    EDIT: AAh, I clicked Tools, Error Console, it says this, "Security Error: Content at http://www.kitamuracomputers.com/tidelog/wp-login.php may not load data from http://www.tidelog.info/."

    I use http://www.tidelog.info to point to my blog on my company server, why is it doing this now after an update to WP??

  9. kopio
    Posted 5 years ago #

    I have checked in both Chrome and Firefox and in both my visual editor is gone, the insert media is gone, many of the normal buttons are grayed out. what is going on with WordPress? It is not just the latest update although it has gotten worse with the last upgrade.

  10. davidmoulton
    Posted 5 years ago #

    Found it - credit to these guys here:

    ..and this is how you implement:
    Add json to your php.
    In cpanel go to PHP PEAR packages. In the "PHP Extensions and Applications Package Installer" type "json" in the "Find a PHP Extensions and Applications Package" field.
    My cpanel offers "Services_JSON (1.0.3 stable)" Click 'install' and you're all set :)

  11. David nailed it. You probably have a JSON problem on your PHp install. Tell your host if you can't install it yourself.

  12. Tidosho
    Posted 5 years ago #

    Uhh, no, that won't fix it for everyone. Like I said, my case is the browser. I don't have cPanel, I'm hosted with One.com and they won't change anything. It also does it on my WAMP testserver which coincidentally already has JSON. None of my admin functions work in Chrome or Firefox, but it does in IE, so how exactly is that PHP's fault when it worked fine right up until I upgraded WordPress, hmm?

  13. Tidosho
    Posted 5 years ago #

    Internet Explorer displays this when I click my Log in link or any other admin link:

    "This content cannot be displayed in a frame

    To help protect the security of information you enter into this website, the publisher of this content does not allow it to be displayed in a frame.

    What you can try:
    Open this content in a new window"

    I open in a new window and it works.

  14. s016752
    Posted 5 years ago #

    Nothing above is working to restore my dashboard and administrative functions since upgrading to 3.2. Has anyone else had any luck?

  15. davidmoulton
    Posted 5 years ago #

    Well that was a short lived victory! I cleared my FF5 cache and the problem returned. I ran the json update on another blog but cannot repeat the successful outcome. Certainly looks like a browser problem. Am running with IE8 temporarily now, which seems ok.

  16. s016752
    Posted 5 years ago #

    How do you run with IE8 :( I have no idea what that is? Is anyone from the WordPress team going to investigate this issue and update the update?

  17. naptunian
    Posted 5 years ago #

    I'm having problems with the widget screen as well. I've tried it in Chrome, FireFox, and IE9. Still no luck.

    I used the health check and it said everything was okay with my dreamhost installation.

  18. naptunian
    Posted 5 years ago #

    this is strange. It's working now...

    All I did was install the Best Tester plugin activate it. (Then had second thoughts). Then deactivated it.

    Now my widgets work...

  19. nicole2292
    Posted 5 years ago #

    I too am having this problem only it appears in all browsers I have - Firefox, Chrome and IE8.

    I have tried deactivating all plugins with no luck.
    I have searched for the "Best Tester plugin" mentioned above but cannot find anything by this name.

    How have others fixed this problem?


  20. nicole2292
    Posted 5 years ago #

    Ok so I have figured out my problem. On the update a couple of the new files did not go up via ftp correctly and were shown in the failed transfers area in my ftp client as there were temp files on the server causing problems. I simply deleted the temp files and the re-uploaded the problematic files and now I can drag and drop widgets again.

    Therefore for anyone else with this problem double check your update has been fully implemented correctly.

  21. davidmoulton
    Posted 5 years ago #

    Just tried the 'fix' for this 3.2.1 but still the same in FF5. OK in IE8.
    (IE8 = Internet Explorer 8.)

  22. philzo
    Posted 5 years ago #

    I share this fix in case it is pertinent to your setup. It works for mine, but may have no use for others.

    I lost drag and drop functionality (and perhaps more) in the menu admin interface after updating to 3.2.1. I was able to get it working again when I commented out the code in my custom functions.php file that was deregistering WP's jquery and replacing it with the library hosted by google. This is what the original code looked like:

    /* 	Deregister native jquery and register google's */
    wp_deregister_script( 'jquery' );
    wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js');
    wp_enqueue_script( 'jquery' );
  23. Raymond
    Posted 5 years ago #

    My issue with drop and drag, widgets not opening, etc... was my theme was out of date and it effected my admin. Took me two days to figure it out !! So if you have these kind of problems, change your theme and see if it works before you spend a lot of time on other things like I did :)

  24. lindaloustarr
    Posted 4 years ago #

    Same issue, am newbie to wordpress (this version since last year), noticed the issue when trying to drop & drag widgets to no avail. Am using 4 different themes for my site through 3 other folders besides root. Installed wordpress correctly into separate folders with separate files and separate wp-config.php for each with separate databases. (Wasn't quite sure where to post this so is posted in one other place with JSON issues; my apology.)

    Called godaddy they wouldn't help with JSON said it was a javascript . . . Completely uninstalled wordpress one by one to be sure my multiple folders weren't causing the issue.

    Downloaded a new wordpress zip file, downloaded winzip just to be sure it wasn't a windows extract all files issue, unzipped, dragged & dropped to my ws_ftp uploader. Tried it on my xp home computer to be sure it wasn't a windows 7 issue (same, couldn't drop/drag widgets in xp either).

    Instead of using ws_ftp auto upload this time, created folders within root itself and uploaded file by file according to ASCII & Binary to root only (no additional folders this time).

    I've trouble shooted from my end all I can & I REALLY need some expertise here. Below is the coding in my php.ini file (which godaddy tech says is current php file)- how/what do I change to get wordpress 3.2.1 to work correctly? I have deleted wordpress so there's nothing to see right now at lindaloustarr.com - Breathe Possibility.

    I went to php.net on the suggestion of godaddy tech and I am out of my league there . . .

    Thank you so very much for your kind & speedy reply :>)
    register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_input_time = 60
    variables_order = "EGPCS"
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

    ; Only uncomment zend optimizer lines if your application requires Zend Optimizer support


    ; -- Be very careful to not to disable a function which might be needed!
    ; -- Uncomment the following lines to increase the security of your PHP site.

    ;disable_functions = "highlight_file,ini_alter,ini_restore,openlog,passthru,
    ; phpinfo, exec, system, dl, fsockopen, set_time_limit,
    ; popen, proc_open, proc_nice,shell_exec,show_source,symlink"

  25. davidmoulton
    Posted 4 years ago #

    Not a theme issue with me. Browser issue. I now have to use IE for any edits to websites.

  26. davidmoulton
    Posted 4 years ago #

    WordPress 3.3 upgrade with FF8 Cannot open or drag widgets.

  27. lindaloustarr
    Posted 4 years ago #

    I fixed my issue by deleting everything and doing a manual install rather than ftp auto - discovered auto doesn't always work the way you would think it should :)

  28. innoscape
    Posted 4 years ago #

    This occurred when I upgraded a WP install from 3.2 to 3.3 today.
    I upgraded via ftp overwriting all files. (WSFTP)
    Successfully upgraded this way dozens & dozens of times on many servers.
    Just not to 3.3 so, I am holding off on my other WordPress 3.x to 3.3 upgrades until my issue here is "fixed".
    My 3.0.1 installs are fine.
    IE8 - Firefox 7.0.1. & Firefox 9.0.1 - Safari 3.2.3 (525.29)
    Cannot drag widgets or expand screen options or help in administration area.
    I have tried the hotfix .8.
    I have re-uploaded all files, again.
    Still have the same issue.
    I am on a cPanel shared server.

    Operating System : Linux
    Server : Apache
    MYSQL Version : 5.0.92-community
    PHP Version : 5.2.12
    PHP Safe Mode : Off (info)
    PHP Memory Limit : 256M (info)
    PHP Max Upload Size : 50M (info)
    PHP Max Post Size : 8M (info)
    PHP Max Script Execute Time : 30s (info)
    PHP Exif support : Yes ( V1.4 ) (info)
    PHP IPTC support : Yes (info)
    PHP XML support : Yes (info)
    I ran ccleaner
    I ran ipconfig /flushdns
    I also dumped all cookies and history via each browsers gui.
    This is an ADMINISTRATION area issue, not a site theme issue but, I switched themes around as I decided it may alter something cached.

    I may have to do a fresh install as @lindaloustarr suggested BUT,
    I have not investigated json yet.
    I have also not deactivated all plug ins yet.

    I will update here.

    Suggestions would be great, solutions would be coveted.

  29. innoscape
    Posted 4 years ago #

    Well, I installed Services_JSON 1.0.3 via cpanel and no help.

    Also a note, file upload window does not appear in Media/ Upload New Media either. Browser uploader or otherwise.

Topic Closed

This topic has been closed to new replies.

About this Topic