WordPress.org

Support

Support » Installation » [Resolved] 3.1.3 upgrade…

[Resolved] 3.1.3 upgrade…

  • I did the Automatic upgrade and it seems to freeze up on do-core-update, anybody have the same problem or fix.

Viewing 15 replies - 1 through 15 (of 21 total)
  • I signed in and out again, just to be sure. It worked. Sorry for the false alarm…

    Maybe not so false because I now can’t manually install my subscribe2 plugin. It comes up with a fatal error. 3.1.3 is running though.

    esmi

    @esmi

    Forum Moderator

    Try:
    – switching to the Twenty Ten theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – re-running the upgrade manually using wp-admin/upgrade.php.

    @brainjured,

    This may be down to a permissions error on the plugins folder. Does the code tell you what the exact fatal error is? If so can you tell us.

    Matt, no I can’t tell you the exact fatal error, it was about a month ago. I wish I could remember. Wouldn’t I get info from my scripts log file? I called my provider but they did not have a backup as far as I needed so I just deleted the plugin and reinstalled it.

    @brainjured,

    It sounds like a file in the upgrade got corrupted if there was a non-specific fatal error and it was resolved on re-installing. At least it’s now sorted.

    Matt,

    Unfortunately, it still does not work. WP is up to date and my update manually says that i have the most recent update. A manual upgrade seems plausible now.

    After trying to activate the plugin, I received this,

    Plugin could not be activated because it triggered a fatal error.

    Warning: main(/blog/wp-content/plugins/subscribe2.php_/include/buttonsnap.php): failed to open stream: No such file or directory in /blog/wp-content/plugins/subscribe2.php_/subscribe2.php on line 56

    Fatal error: main(): Failed opening required ‘/blog/wp-content/plugins/subscribe2.php_/include/buttonsnap.php’ (include_path=’.:/include:/usr/lib/php’) in /blog/wp-content/plugins/subscribe2.php_/subscribe2.php on line 56

    this is the fatal error that I’m talking about. I forgot how to recreate it until I tried activating it again.

    @brainjured,

    Okay – take a minute and read the error message and it tells you the problem.

    ‘No such file or directory’ and the first names file is buttonsnap.php which is being looked for in ‘/blog/wp-content/plugins/subscribe2.php_/include/’.

    The error is telling you that this file is not there. It needs to be.

    Depending on how you install your plugins the issue could well be that you are not reading and following the upload instructions of you are installing manually via FTP or the upload is incomplete due to a software glitch.

    If you installed using the WordPress administration area then the files are somehow corrupted, use FTP software to delete them – if you sue the administration area you will loose all of your settings and subscriber data. Then re-install.

    I installed it by uploading the zip file. I did notice that subscribe2.php was missing too in the error message. Do I need to install a separate php file for subscribe2? Now to delete using the FTP software, just delete the plugin folder. I could also use the file manager through my host, right.

    check that, the subscribe2 folder under the plugin directory.

    @brainjured,

    File Manager would work as well. Delete the subscribe2 folder from wp-content/plugins/ and then upload it in it’s entirety from your local machine.

    I bought HTML version, will it recognize that I did on the install.

    ok, i’m activated now. I uploaded the HTML php file into the subscribe2 plugin folder. Now lets just change a few settings and I should be off, right.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] 3.1.3 upgrade…’ is closed to new replies.
Skip to toolbar