Support » Installing WordPress » 3.1.3 upgrade issues

  • 1. I manually upgraded, uploading only the changed files as listed at http://codex.wordpress.org/Version_3.1.3, but the dashboard still says “You are using WordPress 3.1.2.” (I upgrade in this way because of several customized files over 5 blogs; it’s worked fine for 5 years.)

    Looking at the modification dates, I found a few other newer files:

    wp-admin/network.php
    wp-includes/class-wp-xmlrpc-server.php
    wp-includes/ms-files.php
    wp-includes/version.php

    Updating those files (obviously, the last one most of all) now gets me “You are using WordPress 3.1.3.’

    2. But now, there is an error with every admin page:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'send_frame_options_header' was given in /home/xxxx/public_html/blog/wp-includes/plugin.php on line 395

    That error only arose after updating the above extra pages, although that may have been due to caches expiring, since none of those pages contains call_user_func_array, although it may well be more complicated than that.

    Although admin pages show up, it appears to prevent new posts.

    Where is the problem?

Viewing 15 replies - 31 through 45 (of 61 total)
  • While my blog is working, I feel for you Mickey, as I’m finding issues – but haven’t had to resort to the drastic efforts you’ve made.

    Hope they address it as I’ve never come across an upgrade to cause so many problems!

    anyone have any ideas on how to make wordpress tech support aware of our problems with the upgrade?

    There are no known general issues in WordPress 3.1.3. All of the issues described in this thread appear to be site specific – which means that you are looking at problems caused by plugins, themes, site configurations and/or server set ups.

    sorry, but i dont buy that for a minute. my blog worked perfectly until i upgraded to 3.1.3.

    all themes worked, all plugins worked, all links worked, all pages worked. site configs worked, server setup worked.

    maybe because you have not had an issue with it, you are just lucky.

    there are too many other people who have had problems and all of us cant be doing the same thing wrong.

    there is a problem with 3.1.3 and it needs to be addressed by someone who can fix it, so our blogs go back to working properly.

    I wonder if the manner of upgrading has something to do with these problems. That is: manually upgrading (copying files yourself via FTP), automatically upgrading via WordPress admin, or automatically upgrading via Fantastico or some such service with your host?

    i have never had any problems with upgrading in the past, but this time the upgrade sure screwed up things.

    this morning i totally deleted the blog after copying text info that i had entered in various widgets. also copied my posts to a text file.

    recreated a new blog and did the upgrade. default theme, no plugins, just the bare minimum wordpress 3.1.3

    as soon as i tried to add a new page and test it, all it did was reload the main blog page. so links to pages do not work. anything other than the default permalinks setting still gives a 404 error.

    there is most definitely a problem or problems with this upgrade

    I just created a brand new blog – no plugins, theme or anything. When I clicked to upgrade to 3.1.3, I got this:
    Fatal error: Call to undefined function get_option() in /home/fanpages/public_html/wp-admin/admin.php on line 32

    If I go into my cpanel and uninstall WordPress and start over, everything is fine.

    I guess I will just stick with the older version of WordPress until this problem gets straightened out.

    BJ

    well i went into my cpanel and deleted my blog. all files were deleted.

    created a new blog. no plugins were installed.

    used the default theme and did the upgrade. anything other than the default permalinks setting still gives a 404 error and very little works, like when adding new page.

    so even a fresh install does not fix the problem.

    apparently nobody from wordpress has even seen our messages about the issues. if anyone knows how to actually contact wordpress support, please let us know, so we can make them aware of this.

    There is “WordPress support” other than these volunteer-staffed forums.

    if you would be kind enough to provide where the best source of support is, then by all means, please make us aware if it.

    i will have no problem to try and contact them, if there is chance it could expedite a solution.

    I tried to reset my plugins and theme but it didn’t work, considering that my error is
    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘send_frame_options_header’ was given in /homez.169/bloguons/www/wp-includes/plugin.php on line 395

    Should I reset the whole wp-includes file?
    If I go back manually or automatically on 3.1.2, will I lose the comments on my posts (same quesiton if I reset my wp-include)? If so, is there a way to keep them?

    Anyways thanks for your help all, I m sure we ll fix it!

    All I can do is add my voice to those who have said they are having problems. My blog login page or dashboard page are taking a very, very long time to come up and are not working properly most of the time. I would like very much to know what I could do to fix this.

    My blog is now working again with the 3.1.3 upgrade.

    i did the following:
    1. i copied all of my actual posts from the blog to a text file and saved to my pc.

    2. i copied all text from widgets to different text files and saved on my pc.

    3. i copied all text from misc pages to different text files and saved on my pc.

    i had everything i needed at this point.

    I called my hosting company again.

    i told him all of the things i had done/tried.

    i gave him permission to get into my cpanel and delete the BLOG. i asked him and he said it was possible that each time i deleted the blog and then recreated it, some files may not have been deleted when i did it.

    he did it and made sure there were gone.

    then he created a test blog on my domain. he created 2 pages, 2 posts and had the default theme. NO plugins

    then he upgraded to 3.1.3 and changed the permalinks from default to custom. he tested it and everything worked.

    after i got off the phone, i created the blog again for the umpteenth time.

    with the default them, i created 2 misc pages and 2 posts. they all worked. then i did the upgrade and things still were working.

    then i changed the permalinks from default to custom and checked things out and everything was still working.

    next i changed the default theme to my theme and tested everything. it all was working.

    so at this point, i have a new blog with my theme, 2 misc pages and 2 posts and running on 3.3.1

    then i began to install my plugins. i did them 1 at a time and after each install/activation, i would load the blog and see if it worked or not. EVERYTHING appears to be working as it is suppose to.

    you can essentially do the same thing i did. it may take some time to copy your posts, pages and info from your widgets, but if it resolves the problem, then it is worth the time.

    i was on the phone for maybe 20 mins with tech support and then in less than 30 mins, i had the blog recreated and everything added.

    hope this helps

    Same problem here – on upgrade, admin login disappears. Deactivating plugins makes no difference and I only have three to worry about. However, if I try to access my admin in explorer as opposed to firefix it says ‘cannot open in a frame’ ‘open this content in a new window’ and if i click this, my admin appears and I can login. Any thought?

    hi mickey, esmi made a typo, there’s actually NO support other than these volunteer staffed forums.

    glad you’ve got it working again, but just so you know, the wordpress data is stored in the database and not in files. so to reinstall properly, you actually have to delete the database tables as well. seems like you might have missed that until your host helped you delete the blog properly.

    I updated to 3.13 today and now I get a 404 page for my blog homepage in Firefox (other pages are fine), I get my homepage loaded on IE but it identifies some errors on the page and one of my dynamic widgets doesn’t work. Chrome loads the page without identfying errors but the widget still doesn’t work

    Tried re-installing but no joy.

    Hmmm –any advice?

    Thanks

    Neil

Viewing 15 replies - 31 through 45 (of 61 total)
  • The topic ‘3.1.3 upgrade issues’ is closed to new replies.