Support » Installing WordPress » 3.1.3 upgrade issues

  • 1. I manually upgraded, uploading only the changed files as listed at http://codex.wordpress.org/Version_3.1.3, but the dashboard still says “You are using WordPress 3.1.2.” (I upgrade in this way because of several customized files over 5 blogs; it’s worked fine for 5 years.)

    Looking at the modification dates, I found a few other newer files:

    wp-admin/network.php
    wp-includes/class-wp-xmlrpc-server.php
    wp-includes/ms-files.php
    wp-includes/version.php

    Updating those files (obviously, the last one most of all) now gets me “You are using WordPress 3.1.3.’

    2. But now, there is an error with every admin page:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'send_frame_options_header' was given in /home/xxxx/public_html/blog/wp-includes/plugin.php on line 395

    That error only arose after updating the above extra pages, although that may have been due to caches expiring, since none of those pages contains call_user_func_array, although it may well be more complicated than that.

    Although admin pages show up, it appears to prevent new posts.

    Where is the problem?

Viewing 15 replies - 16 through 30 (of 61 total)
  • Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    i did de-activate all the plugins and tried things. still have the same issues.

    switching between 3 different themes does not do anything either.

    i would go back to 3.1.2 in a heartbeat, if there was a really simple way to do it.

    Since I tried to reset the plugins, I can’t access my admin anymore, or the blog.
    I receive a different error code:
    Fatal error: Call to undefined function add_filter() in /homez.169/bloguons/www/wp-includes/default-filters.php on line 17

    What should I do?

    does anyone from wordpress see this, so they know many of us are having major issues, since upgrading?

    i talked to my hosting account tech support today and they checked stuff on their side and said everything is working OK, so it is a wordpress issue.

    Also having a problem. Everything worked great till I upgraded. Now one add (image google add) is no longer showing up. De-activated plugs in but to no avail…

    Would be great to have 3.12 available. Like mickey65 I would switch in a heartbeat if there was a really simple way to do it. By the look of it there are obviously issues with 3.1.3

    trying different themes did nothing. deactivating my whopping total of 14 plugins and then reactivating them one by one, did nothing.

    i want 3.1.2 BACK. i would certainly like for anyone who works with wordpress support to see the issues and at least let us know that either someone or group of people are aware of the problems and are working on them. the so-called hot-fix plugin did absolutely nothing.

    we all need help ASAP

    Yea i had the white screen of death with 3.1.2 but 3.1.3 installed without problems

    If you need the older version

    http://wordpress.org/download/release-archive/

    If you need to fix your install then follow the normal steps

    disable plugins by renaming the directory
    disable your theme by renaming your current theme unless you are using the wordpress default themes.

    Even if you rename the theme folder you should still be able to login

    Rollback is tougher and you really need your old database
    If you did not make a backup then I would suggest that you reinstall 3.1.3 and hope it cures it.

    Delete the wp-admin and wp-includes folders
    delete your cache folders in your wordpress wp-content folder

    do a manual install
    goto website/wplocation/wp-admin/install.php OR update.php

    however before you update manually
    you need to backup everything you may have now

    Good Luck
    Wont be fun

    http://www.npsites.com

    or join the irc chat on freenode #WordPress
    and I will try to give you a hand

    does anyone from wordpress tech support see our comments about the problems after we have upgraded to 3.1.3?

    this really is getting to be a frustrating problem after all the hard work and time we have put into setting up our blogs and trying to make them something special and useful to others.

    @mickey65: One thing to note with your issue: you have a setup that isn’t recommended. Read http://codex.wordpress.org/Using_Permalinks#Structure_Tags

    Setting your permalinks to just /%postname%/ is a known problem. It is recommended to use /%year%/%postname%/ or some other such combination. Try that and see if your issue is alleviated.

    For the record, the permalinks for one of my blogs are set to just /%postname%/ and that blog is working fine under 3.1.3 (with the Hotfix plugin, although it was working without it, too — I’m not sure when what it fixes is called).

    It seems like many people are having issues with 3.1.3. I will most likely wait for the next release (e.g., 3.1.4) before upgrading.

    My question is this: Is each release cumulative? In other words, can I upgrade to 3.1.4 directly from 3.1.1? Or would I have to first upgrade to 3.1.2 followed by 3.1.3 then 3.1.4?

    Thanks in advance for your help.

    Bro. Chris

    /%year%/%postname%/ did nothing. problem still exists

    deactivated all plugins

    saved new permalink type, reloaded blog
    problem still there 4o4 not found, posts dont show
    changed back to default

    if i really thought it would do any good, i would take a piece of paper and make a note of how the page looks with my widgets. then copy the code for each widget and save as a text file. then copy my posts to a text file. and after i have everything, delete the blog totally and then create a new blog.

    but that is a lot of time and work, if it will not correct the issues.

    I just upgrades a WIP site with 3.1.3 and I can no longer log in to the dashboard. I was logged in and I am still able to work fine, but others trying to log in, or using a different browser is a no-go. I have deactivated all plug-ins, downgraded back to 3.1.2 but nothing is working. Basically, no errors or anything, it just reloads the log in screen. The URL looks like this after an attempted log in.

    http://wip.url.com/wp-login.php?redirect_to=http%3A%2F%2Fwip.url.com%2Fwip%2Fwp-admin%2F&reauth=1

    I’m hosting on GoDaddy which I am not happy with. Soooo slow.

    anyone have any ideas on how to make wordpress tech support aware of our problems with the upgrade?

    this is really getting to be a pain in the ass.

    via cpanel i totally removed my blog. checked via ftp and all files were deleted.

    created a new blog and did the upgrade to 3.1.3

    at this point no plugins were installed and the default theme was used and guess what, the same problem occurs.

    so now i have wasted the time deleting the blog and now i have to recreate it and will still have the same issues.

Viewing 15 replies - 16 through 30 (of 61 total)
  • The topic ‘3.1.3 upgrade issues’ is closed to new replies.