WordPress.org

Support

Support » Installation » 3.1.3 upgrade issues

3.1.3 upgrade issues

  • 1. I manually upgraded, uploading only the changed files as listed at http://codex.wordpress.org/Version_3.1.3, but the dashboard still says “You are using WordPress 3.1.2.” (I upgrade in this way because of several customized files over 5 blogs; it’s worked fine for 5 years.)

    Looking at the modification dates, I found a few other newer files:

    wp-admin/network.php
    wp-includes/class-wp-xmlrpc-server.php
    wp-includes/ms-files.php
    wp-includes/version.php

    Updating those files (obviously, the last one most of all) now gets me “You are using WordPress 3.1.3.’

    2. But now, there is an error with every admin page:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'send_frame_options_header' was given in /home/xxxx/public_html/blog/wp-includes/plugin.php on line 395

    That error only arose after updating the above extra pages, although that may have been due to caches expiring, since none of those pages contains call_user_func_array, although it may well be more complicated than that.

    Although admin pages show up, it appears to prevent new posts.

    Where is the problem?

Viewing 15 replies - 1 through 15 (of 61 total)
  • Note: Reverting only the changed files fixes the problem, so it doesn’t appear to be an error on my part (though that remains a possibility of course!).

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    (I upgrade in this way because of several customized files over 5 blogs; it’s worked fine for 5 years.)

    You are a brave man Charlie Brown. The problem with customizing core WordPress files (that is what you mean right?) is that many of the functions are dependent on other files/functions.

    Looks like you know how to do the full backup safety net already. Have you tried just installing the 3.1.3 completely untouched on top of your installation? Are your mods really required?

    Perhaps your blogs would benefit form child themes too

    http://codex.wordpress.org/Child_Themes

    Gl

    My mods are not drastic (e.g., excerpt length to 80 words, setting 1 column as default choice for galleries, adding/editing quicktags for the editor, customizing the RSS feed). Some day I should put them all into a plugin, but I’m a dabbler and haven’t got comfortable with plugin writing yet.

    When I have time, I will try a clean 3.1.3 install. (I still have to do it manually, because I use a private key for SFTP access, which seems to preclude the automatic update.

    OK, I’m pleased to report that a complete clean 3.1.3 upgrade removed the problem. And everything’s still fine after I swap in all of my modified files. I must have placed some file(s) in the wrong place(s).

    Thanks for taking the time to help.

    One problem I see with modifying functions via plugin or theme is that I’d still have to check them with each upgrade to make sure some new functionality isn’t thwarted. So it actually seems easier to simply change a value in the function. This requires good organization, of course.

    I keep a complete untouched version of the current and previous versions as well as complete versions with modified files tagged (by color in Mac OSX). With a new version, if a changed file is one that I’ve modified I compare a copy of it with my modified file (in BBedit) and apply the modification.

    With major upgrades, since the files are often more drastically changed, I refer to notes of the modifications I’ve made, so I can reapply them if necessary.

    Is anyone having problems accessing their dashboard since upgrading to 3.1.3? Cos I am

    I’m getting white screen on dashboard and other pages/posts etc but the external site is viewable; help!

    I am having problems as well, I got an Arcade Plugin and nothing works as should work. Even my website doesn’t work properly. Everything is wrong and out of place ? There is a way to return to a previous version of WordPress or a re-install ?

    HELP PLEASE

    Deactivate all plugins by renaming wp-content/plugins folder to e.g. wp-content/pluginsx via FTP

    Then install and activate http://wordpress.org/extend/plugins/hotfix/

    Hello:
    I installed word press using a subdomain name and I can’t upgrade to 3.1.
    It comes back upgrade failed then it asks me for my Cpanel info,after I install that and try again it repeats it self.
    I have been having this issue right from the first time.

    Hi all, thanks for the replies.

    Still a mess, specially with Dashboard!?

    Any other help ?

    thanks

    prior to upgrading to 3.1.3 my blog worked fine. after the upgrade, if i set my permalinks to /%postname%/, i get a 404 error – not found message and no posts appear.

    if the permalinks are set to default, the posts appear, but i have no access to my rss feeed.

    my other blog is still at 3.1.2 and it all works perfect.

    i tried the plugin fix and it did nothing, so i still have the same problems

    Hello,
    I have the same problem with my blog (www.bloguons.net) that I just updated to 3.1.3. It’s a brand new blog so there was nothing on it before. I posted two articles and had it for 3 days without noticable problems, when I tried to instal social plugins this error appeared:
    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘send_frame_options_header’ was given in /homez.169/bloguons/www/wp-includes/plugin.php on line 395

    When I delete the different plugins it remains, even if before the installation I didn’t have any error message.
    I tried the Hotfix technique and it didn’t work.

    Should I go back to 3.1.2 also? (I just want tto be sure cause I don’t master these tools very well)
    Thanks!

Viewing 15 replies - 1 through 15 (of 61 total)
  • The topic ‘3.1.3 upgrade issues’ is closed to new replies.
Skip to toolbar