WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 3.1.3 Upgrade is conflicting with themes

[Resolved] 3.1.3 Upgrade is conflicting with themes

  • The new upgrade seems to have caused some error messages to pop up in the admin section.

    I have no plugins activated, and all of my themes are updated. Also, twenty-ten works fine.

    3.1.3 seems to conflict with the themes I have installed, and all of the problems seem to be with the theme’s function.php file.

    For example, when I have the ‘powered-by’ theme installed, this error pops up when I make a new post:
    Notice: Undefined index: powered_by_featured_page_nonce in /misc/28/000/215/334/9/user/web/davewhitley.com/x7ej81jf/wp-content/themes/powered-by/functions.php on line 239

    Other problems show up with the ‘sandbox’ theme as well. Again, relating to the themes function.php.

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Yes, as stated above all my plugins are inactive, and I have also concluded it is a problem with the themes because twenty ten does work fine.

    Every time it is an error with the theme’s function.php. Since theses are reputable themes, I’m guessing WP has recently changed something that would make the error show up. I’m not sure.

    This is a testing WP site so I haven’t even touched any code:
    http://www.davewhitley.com/x7ej81jf/

    esmi

    @esmi

    Forum Moderator

    The themes just haven’t been correctly coded. Sorry but that’s all there is to it.

    Alright, that is probably it.

    esmi

    @esmi

    Forum Moderator

    Unfortunately, buying a theme is no guarantee of coding quality. In comparison, all themes submitted to http://wordpress.org/extend/themes/ since June 2010 have had to pass a review that looks for these kinds of issues. You can even download a plugin and check themes yourself: http://wordpress.org/extend/plugins/theme-check/

    Actually, all of the themes I am having problems with are from the Free Themes Directory, so they have been tested and such. The themes I have mentioned are well-used development themes (sandbox, toolbox, thematic). I just seems weird to me that they would have so many errors. Something isn’t right.

    Update: I have found an error that isn’t theme-specific:
    Notice: Array to string conversion in /misc/28/000/215/334/9/user/web/davewhitley.com/x7ej81jf/wp-includes/query.php on line 2390

    Since this is a problem with wordpress and not a theme, I may just do a clean install or something.

    Actually, this is kinda silly.

    I think that messages I have been receiving are from the WP DEBUG. Or at least I hope that is the only problem.

    Thanks for all your time esmi.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] 3.1.3 Upgrade is conflicting with themes’ is closed to new replies.
Skip to toolbar