WordPress.org

Forums

BackWPup Free - WordPress Backup Plugin
[resolved] 3.1.2 broke Dropbox for me (30 posts)

  1. djoolfr
    Member
    Posted 1 year ago #

    Hi there,

    Since installing 3.1.2 yesterday, I have now the following message in the log file:

    [28-fév-2014 04:21:21] ERREUR: DropBox API: (59) Unknown cipher in list: ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:ECDHE-RSA-RC4-SHA:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-

    When I try to re-authenticate, the same message is displayed:

    DropBox API: (59) Unknown cipher in list: ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:ECDHE-RSA-RC4-SHA:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-

    What can I do to restore dropbox functionality?

    Thank you very much and congrats for a well-made plug-in!

    Background info: it worked in 3.1.1. I have a daily backup job that saves the files and the database to the local filesystem and to dropbox. Server is running linux CentOS 6.5.

    https://wordpress.org/plugins/backwpup/

  2. Peter vanDoorn
    Member
    Posted 1 year ago #

    Glad I'm not the only one!

    ERROR: Dropbox API: (59) Unknown cipher in list: ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:ECDHE-RSA-RC4-SHA:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-

    Across all my sites!

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    @Peter vanDoorn: It is considered impolite to interrupt another poster's ongoing thread unless you are posting a solution or suggestion. As per the Forum Welcome, please post your own topic.

  4. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    You can try the follwoing mini Plugin to get it work again.

    <?php
    /**
     * Plugin Name: BackWPup disable SSL connection verifying
     * Plugin URI: https://marketpress.com/
     * Description: Disables the verifying from SSL connections in backup destinations
     * Author: Inpsyde GmbH
     * Author URI: http://inpsyde.com
     * Version: 0.1
     * Network: true
     * License: GPLv3
     * License URI: http://www.gnu.org/licenses/gpl-3.0
     */
    
    add_filter( 'backwpup_cacert_bundle', 'backwpup_disable_ssl_verify' );
    function backwpup_disable_ssl_verify ( $file ) {
    
    	return FALSE;
    }
  5. djoolfr
    Member
    Posted 1 year ago #

    Hi Daniel,

    Thank you very much - installing the mini plugin did the trick!

    I have a few remaining questions and hope you can shed some light on this:

    - are we still using SSL when connecting to Dropbox?

    - i understand from other posts that this won't be included in the standard code, so I can just leave the fix enabled even for future versions?

    Thanks again,
    Julien

  6. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, SSL will used. But the Certificate will not checked.
    Yes, you can lave it enabled.

  7. djoolfr
    Member
    Posted 1 year ago #

    Thanks a lot Daniel!

  8. Kramarz
    Member
    Posted 1 year ago #

    A question to clarify, Before I update BackWPup across all the websites.

    All of the websites I made are using dropbox for backups - will updating plugin now break this and I will have to use the fix above to solve it?

  9. djoolfr
    Member
    Posted 1 year ago #

    Not necessarily I guess. But if you encounter the same problem, here's a fix.

    I don't have a proper SSL certificate installed on my server so maybe this is causing the problem. But this is just a guess.

  10. sbailey4
    Member
    Posted 1 year ago #

    Same issue here. My fix was to remove 3.1.2 and re-install 3.0.13. That version seems to work better than 3.1, 3.1.1 or 3.1.2 for me across the board.

  11. stepatty
    Member
    Posted 1 year ago #

    How do I reinstall 3.1.1? Where can I find it?

  12. sbailey4
    Member
    Posted 1 year ago #

    on the developer tab of this support page are the older versions

  13. stepatty
    Member
    Posted 1 year ago #

    Hi, sbailey4,

    I downloaded 3.1.1 from the developer tab, but I can't figure out how to run it. I can open the folder, but there's no option for me to install the files.

  14. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    Can You Pleas post the "[INFO] curl ver.:" from a logfile.
    I think it depends on the curl SSL Version that will be used.

  15. djoolfr
    Member
    Posted 1 year ago #

    Hi Daniel,

    This comes from a logfile of mine:

    [INFO] curl ver.: 7.19.7; NSS/3.14.0.0

    Cheers,
    Julien

  16. wtankwey
    Member
    Posted 1 year ago #

    What is the actual name of Mini plugin to install?

  17. wtankwey
    Member
    Posted 1 year ago #

    @ djoolfr,

    How did you installed that mini plugin? can you help?

  18. djoolfr
    Member
    Posted 1 year ago #

    Hi there,

    To install the mini plugin:

    Copy the portion of code provided by Daniel in an empty text file, save it as backwpupsslfix.php and put it in /wp-content/plugins/ using an FTP client.

    Then refresh the installed plugins page in WordPress and activate the plugin.

    Hope this helps!

  19. wtankwey
    Member
    Posted 1 year ago #

    @ djoolfr,

    It is finally working for me. Thanks a lot.

  20. FineHomes
    Member
    Posted 1 year ago #

    @ djoolfr, hello and thanks for your help

    Are you saying another plugin called backwpupsslfix.php should show up in the list of plugins??

    When you say activate the plugin do you mean activate the backwpupsslfix.php plug ????

    I put the code in a text file and uploaded it to /wp-content/plugins/ using an FTP client but there's no new plugin in the list of plugins and nothing new to activate.

    I'm getting the same error

  21. wtankwey
    Member
    Posted 1 year ago #

    it should be saved exactly under the following name: backwpupsslfix.php

    And you should see it under the inactive plugins list under the following name: BackWPup disable SSL connection verifying

  22. wtankwey
    Member
    Posted 1 year ago #

    I just did it and it is working.

  23. FineHomes
    Member
    Posted 1 year ago #

    I'm happy it's working for you.

    I saved the file as backwpupsslfix.php

    I uploaded the file to /wp-content/plugins/. I can see it in the file list

    there is nothing new called BackWPup disable SSL connection verifying
    in the inactive plugins list

  24. wtankwey
    Member
    Posted 1 year ago #

    Sorry to hear that.

    One more thing. Just remember to refresh your installed plugin page and re-check your inactive plugins list

  25. FineHomes
    Member
    Posted 1 year ago #

    Thanks.

    did both those things

  26. FineHomes
    Member
    Posted 1 year ago #

    My stupid mistake. It's uploaded and activated.

    Now I have this:
    "WARNING: Job has done with warnings in 527 seconds. Please resolve them for correct execution.WARNING: Job restarts due to inactivity for more than 5 minutes."

  27. wtankwey
    Member
    Posted 1 year ago #

    Glad that the mini plugin is working for you.

  28. whites7
    Member
    Posted 1 year ago #

    Thanks...the mini plugin also worked for me.

  29. mrkingid
    Member
    Posted 1 year ago #

    will this issue be fixed in 3.1.3?

  30. LO
    Member
    Posted 1 year ago #

    With so many users (including myself on five sites) encountering this bug in 3.1.2, wouldn't it be better to push a fix now rather than to recommend an awkward "mini plugin" in the undefined interim?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.