WordPress.org

Support

Support » How-To and Troubleshooting » 3.1.1 update broke my site completely

3.1.1 update broke my site completely

  • It’s all in the title, really. I’ve just made the upgrade to 3.1.1 and now I’m getting nothing but a blank page. I noticed the previous similar post, but since I’m not using multisite, the lines discussed in the fix do not appear in my wp-config.

    Halp!

Viewing 15 replies - 1 through 15 (of 18 total)
  • Since I’m not seeing a multitude of similar cries for help, I guess this isn’t happening for most users. The only untypical factor I can think of with my WP installation is that I use a splash page on the root of the site (http://www.nexistepas.com/) and the blog posts appear at http://www.nexistepas.com/enthuse/ – there is nothing at all to see at either of these links at this point, nor at the admin address…

    try downloading a fresh copy and uploading the files manually. the 1st attempt might have failed halfway.

    I would make sure you followed all of the instructions here: http://codex.wordpress.org/Upgrading_WordPress_Extended

    Specifically try to disable all of your plug-ins and see what happened.

    I have been trying to update a blog from 3.0.4 to 3.1.1 and getting nowhere with the automatic updater.

    I replaced the wp-admin and wp-includes directories, and updated the remaining files, and then I got a blank page.

    Replace the old wp-admin and wp-includes directories and it all works fine again. Good job I renamed them instead of deleting!

    Moderator kmessinger

    @kmessinger

    Was there a question here? ^:)

    Have you tried the manual install? http://codex.wordpress.org/Installing_WordPress#Detailed_Instructions

    Okay, I’ve just manually upgraded. I can now reach the dashboard, but the blog pages continue to be blank. I haven’t re-installed any plugins or my custom theme, so the installation at this point is totally vanilla. Any further ideas?

    what is the content of index.php?

    I assume that your wp-config is set up correctly?

    Sorry, I don’t have any better ideas, not an expert. Wish I could help more. I just wanted to try and cheer you up by pointing at the irony between your domain and your pages being blank 🙂

    Good luck

    Moderator kmessinger

    @kmessinger

    enthusemarc Check the config.php file for a blank line at the end. Rename the plugins folder (I assume your old plugin sre there, just disabled).

    Can you post a URL?

    hairydog Not much in index.php,

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

    The index.php is the one that came in the 3.1.1 upgrade, unedited.

    My wp-config is the same as it was this morning, before I made the upgrade. (I tried changing the line

    require('./wp-blog-header.php')

    removing the “./”, no luck. I’ve since changed it back.

    I’ve also just checked that it wasn’t a cache problem, nor a browser-specific thing. It isn’t.

    I’m sure this is going to something very simple, but right now I don’t know what else to try.

    kmessinger: there is no blank line at the end of wp-config. (I remember that solving a problem in an earlier upgrade, years ago.)

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    I decided to try again.

    I removed everything except wp-config.php and the wp-content directory.

    Uploaded the 3.1.1 files again, and this time it worked!

    Well, something just went right. Blog pages are now loading, after a fashion. One of the following seems to have done the trick:

    • deactivating Akismet (the only active plugin on the site at present)

    • renaming the plugins folder to something WP would not recognise

    • refreshing the wp-admin folder (for the second time)

    Now to reintroduce plugins and themes. I’ll let you know how it goes, and thanks to all…

    Okay, themes and plugs back on, and everything’s fine – or rather, it will be, once I’ve tweaked the widgets. Thanks again…

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘3.1.1 update broke my site completely’ is closed to new replies.