Support » Themes and Templates » 3.1 Failed Update: Themes not compatible with 3.1

  • Resolved shonie777


    I upgraded to the so-called latest and greatest version of wordpress 3.1 last week and it was a nightmare. My wordpress site had the following error:
    Parse error: syntax error, unexpected ‘;’, expecting T_STRING or T_VARIABLE or ‘$’ in /home/kayenta/public_html/blog/wp-content/themes/cutline-3-column-split-11/header.php on line 5

    I tried everything (clean install, manual install, disable plug-ins, etc) available on this forum to fix the issue with no luck. I contacted my host technical support to see if they could fix the problem and they responded with this:


    The reason why your wordepress installation are actually not wrking is
    that our malware scanner have detect some malicious code in your files:

    {HEX}php.cmdshell.fx29.193 :

    {HEX}gzbase64.inject.unclassed.14 :

    {HEX}gzbase64.inject.unclassed.14 :

    {MD5}php.cmdshell.unclassed.2091 :

    {MD5}php.cmdshell.unclassed.2091 :

    We cannot restore this files because this will also restore the phpshell
    at the same time. This kind of files can compromise the whole server

    Let us know if we can provide further support or if you have any questions.

    Simon B. [iWeb]
    Conseiller Senior Support Technique
    Senior Agent Technical Support
    Support / Client Hub :

    It took them nearly a week to get back to me with this info. My host tech support sucks.

    After the upgrade to 3.1, I was always able to login to my admin page. So, for the heck of it I decided to try the default word press theme to see if it would bring my wordpress site back up. After all I had tried everything else with no luck, so I had nothing else to loose.

    After activating the word press default theme, my wordpress site came back up! Woo Hoo!!! It may not look too pretty, but at least it’s back up!

    This is the 3rd time I’ve done one of wordpress’s major upgrades that they are so proud of and it has taken my site down. Everytime I see that fricking “NEW WORDPRESS UPDATE” button I cringe because I never know what it’s going to do to my site.

    It would be nice if they tested it out really well before releasing it to us. It would be even nicer if they stepped up to the plate and stated, “This upgrade could possibly jack-up your site. If it does, we will help you get your site back up and running.”

    Wishful thinking huh?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Erik


    It sounds like a problem with the themes you are using, not wordpress itself.

    What theme were you using when this occurred can you link it here?

    Also, files named “info.php_.gif” certainly don’t appear to be normal. It sounds like maybe your theme was hacked, poorly coded, or both.

    If this “cutline 3” theme is what you were using, it appears to have been last updated on June 25th, 2010, around the time of the wordpress 3.0 update.

    You do realize that is not responsible or accountable for maintaining 3rd party themes? Your theme author, whoever made the Cutline theme, is responsible for either coding the theme to work with updates, or releasing updates to the theme to coincide with changes to the wordpress core install.

    Either way, this is 100% an issue with your theme and it’s coding, not wordpress.

    Chip Bennett


    Theme Review Admin

    You have, at some point in the past, installed a Theme with malicious code (perhaps something like this), that propagated itself to the rest of your Themes.

    If I were you, I would

    1) Delete everything from \wp-content\themes

    Yes: delete every single installed Theme

    2) Download TwentyTen from the WPORG Theme Repository, and upload it manually.

    3) Then, if you wish, download directly from the developer or from the Repository clean copies of any other Theme you want to install (such as Cutline), and then upload them manually.

    To Repeat: none of this is WordPress’ fault. You installed a Theme that contained malicious code.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘3.1 Failed Update: Themes not compatible with 3.1’ is closed to new replies.