Support » Installing WordPress » 3.1 -> 3.3.1: broken on nginx fastcgi

  • Hi!
    I have a test installation of WP on my computer, under Squeeze, that runs under nginx 1.0.4 and the distributed php package(s). The software itself is installed under the url /blog/wordpress. When I tried to upgrade to 3.3.1, everything broke down, so I started over: create an empty database, move the original installation aside, untar the distribution, and just start over. First problem: /wp-admin/install.php yields a 404, but the installation works nevertheless, except that it hangs after pressing “Install blog” (abort, press the button again -> OK). Second problem: The admin interface is basically unstyled, as the urls /wp-admin/, …/load-styles.php, and …/load-scripts.php all yield a 404, while every other url works.
    Putting another installation alongside this, but powered by Apache2 and mod_php worked just fine. Do I see a reoccurrence of ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi RichardWPG, sorry for not reading (finding!) all relevant info before posting, but after reading your response, I have to (re-) state the following:

    * My server’s requirements are met: I have php 5.3.3 and mysql 5.1.x.
    * The problem exists _when_trying_to_install_from_scratch_ (ie, no upgrade problems). I only tried to upgrade first, then starting again from a clean slate, after the upgrade failed. No content/plugin/whatever involved except for whatever is included in the 3.3.1 distribution tarball.

    What I forgot to mention: I had to enable php output buffering in my php.ini in order to get this far, and, using the same setup, other php applications (s9y, t3, joomla, custom stuff) work without any problem, as did wp 3.1.1.

    Forgot to say that I’ve flushed my browsers’s cache, deleted the cookies, and restarted the browser(s) several times in the process, too, so I reckon there was really no stale data lingering around.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘3.1 -> 3.3.1: broken on nginx fastcgi’ is closed to new replies.