Support » Installing WordPress » 3.0>> Image upload broken

  • When I try to upload an image to a post, I ma taken to a new page with the upload tool instead of the lightbox. Once I upload the image, I can’t get back to the create post page.

    How can I get the lightbox to work again?

    The lightbox works in other areas.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Also, I just noticed that when I click on the insert image icon it shows this link:

    http://extantmagazine.com/wp-admin/media-upload.php?post_id=1613&type=image&TB_iframe=1

    On another install of 3.0 it shows this link that produces the pop up:

    http://extantmagazine.com/wp-admin/media-upload.php?post_id=1613&type=image&TB_iframe=1&width=640&height=615

    Any clues as to how to fix this? I’ve tried reinstalling 3.0 and it still wont work.

    Hey David,

    Same issues on our sites, the image uploader doesnt open in a new window it opens in the same window and doesnt seem to allow you to insert.

    Hey David, as said elsewhere it appears to be headspace, and I have narrowed it down to the tags option, if you take that off, headspace works find and so does wordpress

    cakesmcfee – thanks for the feedback. How do I take off the tags option?

    Same issue here with the image upload. Turned OFF the plugin “Headspace” and everything works fine.

    Hi there,

    I’d just like to contribute my experience with the same thing.

    After the 3.0 upgrade I had the same problem with the media loader and a related problem with the Publish box where the drop down menus weren’t working.

    I tried updating Headspace 2, but to no avail. Only deactivating got everything functional again.

    I’m having the same problem. Media upload goes to a new page instead of using thickbox. Some how the following code is breaking it. Any thoughts? I need to be able to tag pages AND upload images.

    I am using the following code to add tags to pages. When I take it out the media upload works fine.

    // Make the metabox appear on the page editing screen
    function tags_for_pages() {
        register_taxonomy_for_object_type('post_tag', 'page');
    }
    add_action('init', 'tags_for_pages');
    
    // When displaying a tag archive, also show pages
    function tags_archives($wp_query) {
        if ( $wp_query->get('tag') )
            $wp_query->set('post_type', 'any');
    }
    add_action('pre_get_posts', 'tags_archives');

    I think the Javascript from the Tag meta box is interfering with the thickbox script.

    esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    – increasing the memory available to PHP?
    http://wordpress.org/support/topic/253495#post-1017842

    I deactivated all the plugins, am using the default theme with no modifications and it still doesn’t work. Did I get a corrupted version of wordpress?

    esmi

    (@esmi)

    Forum Moderator

    It’s possible. Try re-uploading all files & folders – except the wp-content folder – from a fresh download of your version of WordPress.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘3.0>> Image upload broken’ is closed to new replies.