3.04 -> 3.1 upgrade, win2k, IIS5, cannot login to Admin (33 posts)

  1. echodave
    Posted 5 years ago #

    Upgrade was a little clunky...ran through the fix found here for the homepage failing to load, public side of the site is now functioning properly.

    However, when going to /wp-admin/...

    1. Login screen appears

    2. Attempt to login with proper credentials

    3. Screen refreshes...right back to the login screen

    4. Repeat attempt with proper credentials

    5. Same result - back to login screen

    6. Attempt to login with bad credentials

    7. Failure appears as expected.

    As a result, my assumption is that this is not a database issue nor a user issue, but perhaps something to do with redirects in the same manner that the homepage needed a plugin to fix the issues seen there.

    Thoughts and/or assistance greatly appreciated.

  2. benjamin
    Posted 5 years ago #

    I had a problem like this and it turned out to be one of my plugins. I had to connect via FTP and delete the plugins and then I was able to login. Could be the same sort of issue here.

  3. echodave
    Posted 5 years ago #

    Here's the *truly* bizarre part of things.

    I'm having this problem remotely.

    Buddy sitting at home that actually ran the upgrade...in the browser that's logged into the admin section, the one he ran the upgrade with...totally fine. He can do anything and everything - click around, enable plugins, disable plugins, no problem.

    However, he fires up a "clean" browser...and has the same problem I do.

    We'll give the plugins a shot, and see what's up. Thanks for the response.

  4. Jeff Mackey
    Posted 5 years ago #

    Hi, it's me, the "buddy".

    The problem he's describing continues to happen even when I disable ALL plugins and revert the theme back to TwentyTen defaults.

    I suppose I could actually delete the plugin directories and try again, but you'd think that they're disabled would prevent any functionality from happening...

  5. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you tried checking through the solutions suggested in Troubleshooting WordPress 3.1 - Master List

  6. echodave
    Posted 5 years ago #

    Have you tried:
    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    Let me be more clear - there is no way to "de-activate" plugins. I cannot access the Admin side of the site.

    I have, however, renamed the folder and all subfolders. They are inaccessible.

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    Yes. Same problem.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Yes. Same problem.

    - If all else fails, manually upgrade. Download a fresh copy of the latest.zip file of 3.1 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

    Yes. Same problem.

    I've read the other threads as well...I wish this wasn't being so casually dismissed.

    In short, yes, I tried to not be a complete n00b who didn't take the time to read the FAQs, search for possible answers, and look through the open threads to see if I experienced something similar.

    I see other threads where the front-end had the same problem we experienced, and they all resolved the same way we have.

    I see other replies from people that are experiencing the same issue with the Admin side of the site...and those do not appear to have been answered or even acknowledged as "valid errors" as of yet and are being dismissed.

    The particularly weird thing here is that I've dug into the logs. I see a lot of "302", "304" and "200" status errors. Which doesn't make a whole lot of sense to me...because then I go to the paths and file names referenced, and the files are not only there, but contain no notations or references at all to being used for the redirect purposes indicated by those codes. I have checked the web server settings just to be safe, and nothing in there as well.

    If it helps at all, I'm going to attach the (somewhat sanitized, just to be safe) logfiles here...at least the specific references that I mentioned above that show the error messages that don't make sense...but certainly seem to be related here.

    [Code moderated as per the Forum Rules. Please use the pastebin]

  7. echodave
    Posted 5 years ago #

    I've downgraded to 3.0.5.

    Really not all that interested in waiting for an admission of an issue.

    I'll be playing on a dev copy of the site. When someone's interested in working through this, I'm more than happy to make myself and my server available for testing purposes.

  8. articulategabe
    Posted 5 years ago #

    Having a similar issue on IIS.

    I'm also running WordPress on IIS. WP 3.0.5 worked great for all my instances. Just tried upgrading one instance to WP 3.1 and cannot access WP admin at all, either.

    Browser tries to take me to /wp-admin/upgrade.php and then nothing loads - just a blank white page (FF4 beta 11). Chrome gives me a server error:

    The website encountered an error while retrieving SITEURL/wp-admin/upgrade.php?_wp_http_referer=%SITEURL%2Fwp-admin%2F. It may be down for maintenance or configured incorrectly.
    Here are some suggestions:
    Reload this web page later.
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    (I added SITEURL in place of actual URL.)

  9. ssgumby
    Posted 5 years ago #

    I too am having this issue. Exact same steps as echodave.

    echodave, was "downgrading" as simple as pretending to upgrade with a 3.0.5 base? Meaning ill unzip, follow the manual upgrade install using 3.0.5? I just wondered if the db upgrade would bomb or if I should restore my old db first.

  10. echodave
    Posted 5 years ago #

    Here's what I did to downgrade:

    - I turned the site off

    - I followed the steps located here: http://codex.wordpress.org/Upgrading_WordPress_Extended

    - Specifically, I deleted everything it said to delete, kept everything it said to keep.

    - Unzipped 3.0.5 over the directory structure

    - Hit the admin section of the site

    - Logged in

    - It said "run database upgrade"

    - I clicked it (it didn't really do anything)

    - Voila, up and running again on 3.0.5 without a problem.

    Since it doesn't seem like this is getting fixed, and I want to keep using WordPress, I'm converting everything on that server to Apache. It's a PITA, but it'll be worth it in the long run, I suppose.

  11. ssgumby
    Posted 5 years ago #

    Did you use 3.0.5 or 3.0.5-IIS?

    I just tried 3.0.5-IIS and have the same issue

  12. ssgumby
    Posted 5 years ago #

    Here is the thing.

    I go to http://www.mysite.com/blog/wp-admin and it redirects me to


    I enter credentials and hit Log In and it just redirects me back to the above link. If I enter an invalid password I get the error message so its recognizing my credentials but wont allow me into the admin.

  13. echodave
    Posted 5 years ago #

    I used 3.0.5 IIS.

    To be clear, my situation was *slightly* different, though I don't know how much of an impact it would have on the situation.

    - I was at 3.0.4 running fine
    - Upgraded straight to 3.1, went sideways
    - Rolled back to 3.0.5...which was still an upgrade over where I was

    So...I don't know if that had anything to do with it.

    One other thing I realized that I neglected to mention (sorry) was that I followed the instructions about creating a folder named /mu-plugins/, and in it I placed the canonical redirects fix: http://wordpress.org/extend/plugins/permalink-fix-disable-canonical-redirects-pack/

  14. ssgumby
    Posted 5 years ago #

    How do you

    switching to the Twenty Ten theme to rule out any theme-specific problems.
    if you cant get to the admin? Can I do that direct in the db someplace?

  15. echodave
    Posted 5 years ago #

    My buddy was still logged into the admin after the upgrade went sideways, and he was able to do it.

    That was the seriously insane part - he was logged in and stayed logged in...but if he opened a new browser, or I tried to login...we got the exact same symptoms you wrote.

  16. BlogMasterG
    Posted 5 years ago #

    I realized that I'd used the standard 3.1 install. Just updated with the 3.1-IIS version and it works fine for me now - can login to admin again.

  17. echodave
    Posted 5 years ago #

    Good news!

  18. iuchewie
    Posted 5 years ago #

    Same issue - very irritating that this isn't being addressed. I've got 4 other blogs that don't have the issue.

  19. echodave
    Posted 5 years ago #

    Okay, so let's walk through what's different about the one that has the issue.

    - Are all of the configurations the same?

    - Do they all use the same naming convention and pathing? I.e., are they all sitting at "somedomain.com/blog", or are some configured differently than others?

    - Are they all sitting on the same server?

    If you have no issues with three...but you do with number four...then to me, you're looking at something that's different or "wrong" with that one instance as opposed to things in general.

    Find the break in the pattern, and you'll find your fix for #4.

  20. echodave
    Posted 5 years ago #

    Sorry - "the fix for #5" since you have four working :) I should read more before I hit "post"...

  21. ssgumby
    Posted 5 years ago #

    Here are my findings.

    1. Start on version 2.2 (works)
    2. Upgrade to 3.0.5 IIS (cant get into admin, but main site works)
    3. Upgrade to 3.1 (redirect loop on main site, fixed with plugin, cant get into admin)
    4. Restore back to 2.2 (everything works fine)

    This is all done on the same server.

  22. echodave
    Posted 5 years ago #

    When you say "upgrade to 3.0.5 IIS"...are you jumping straight from 2.2 to 3.0.5, or are you doing the incremental upgrades along the way?

  23. ssgumby
    Posted 5 years ago #

    I went straight to 3.0.5, was that bad? I didnt realize I needed to do incrementals.

  24. iuchewie
    Posted 5 years ago #

    @echodave - the only difference is that WP on the one in question is installed in the root rather than a /blog directory.

    The ones that work:

    The one that DOESN'T work:

    At this point, they're all on 3.1. I've tried backing the "bad" one down a version but that didn't seem to work either. All plugins have been deleted (not deactivated) at this point. Could it be a theme issue?

  25. ssgumby
    Posted 5 years ago #

    Ok so here is my story with a working ending.

    I was on 2.2 so I upgrade to every point up to 3.0.5 and tested along the way. It worked! I am now on 3.0.5. When I say every point I mean 2.2->2.3->2.5->2.6->2.7->2.8IIS->2.9IIS->3.0IIS->3.05IIS

    Thanks for the patience here, I am fine with 3.0.5, dont think I need 3.1 anyway. Ive been on 2.2 for so long seeing this new admin im like WOW.

  26. iuchewie
    Posted 5 years ago #

    Back at home tonight, and I can login just fine - looks like I'm having the same issue as @echodave. Any thoughts on a course of action?

  27. iuchewie
    Posted 5 years ago #

    VERY weird... I've logged out and even rebooted my home computer... STILL can get in just fine. What's going on here?

  28. articulategabe
    Posted 5 years ago #

    I spoke too soon... tried upgrading another instance to 3.1 and same issue - cannot login to admin again. Very strange. I somehow got 3.1 working fine in one instance, but not another (same IIS web servers and database server).

  29. iuchewie
    Posted 5 years ago #

    Just realized... the other "difference" between the "bad" instance and the others... that's the only one running IIS. Might be time to migrate.

  30. judahstevenson
    Posted 5 years ago #

    I was also experiencing problems with a fresh 3.1 install on IIS 6. I was getting a redirect loop when trying to access the front-end of the site which I solved by installing a plug-in, but later realized that jquery was failing to load correctly on the back-end. After trying to chase down a solution to the javascript problem I decided to the just downgrade per the instructions detailed by @echodave above.

    I have a feeling that IIS is behind the problems (it usually is with phantom problems like these on our wp installs), but I'm not capable of accurately diagnosing that.

    The downgrade was totally painless so I think I'll just hold off on 3.1 for now.

Topic Closed

This topic has been closed to new replies.

About this Topic