WordPress.org

Support

Support » Plugins and Hacks » 3.0.11 gives redirect error…

3.0.11 gives redirect error…

  • Hi

    Updated from 3.0.10 to 3.0.11 and afterwards canĀ“t get acces to wp-admin – it says: “net::ERR_TOO_MANY_REDIRECTS”. If I rename the plugin directory i get acces again. I have tried reinstalling the plugin wit no luck.
    Guess there must be a bug?

    Any clues?

    / Morten

    http://wordpress.org/extend/plugins/backwpup/

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Author Robert Windisch
    Member

    @nullbyte

    Hi Moxtell,

    thank you for your hint. Please try to change the following line in the backwpup.php file

    if ( ! get_site_option( 'backwpup_about_page', FALSE ) )

    into:

    if ( ! get_site_option( 'backwpup_about_page', FALSE ) && $_REQUEST[ 'page' ] != 'backwpupabout' )

    That should fix the redirect problem on your installation.

    regards,
    Robert

    davidpaulsson
    Member

    @davidpaulsson

    This solution works, confirmed.

    But it’s a hassle to go around and change this on all sites with BackWPup installed. Any patch update coming soon to adress this issue? As it completely blocks acces to the admin while this error occurs.

    Plugin Author Robert Windisch
    Member

    @nullbyte

    Hi davidpaulsson,

    thank you for your response. We will deploy an update for BackWPup asap.

    regards,
    Robert

    mll
    Participant

    @mll

    Robert’s fix didn’t work for me.

    Removing BackWPup set my sites back to work.

    lynnmedia
    Member

    @lynnmedia

    Mll — I am in the process of trying to fix right now. Mll, did you just delete the BackWPup plugin folder?

    lynnmedia
    Member

    @lynnmedia

    Removing the folder worked for me. I tried the code change first, it didn’t work.

    mll
    Participant

    @mll

    lynnmedia : I actually renamed

    /wp-content/plugins/backwpup

    to

    /wp-content/plugins/backwpup.bak

    Little help needed…

    First I renamed folder backwpup.bak and still received this error.

    Then I removed plugin folder via FTP and I still receive error (??!!).

    What now?

    Thanks!

    -Josh

    lynnmedia
    Member

    @lynnmedia

    Have you “hard” refreshed your browser? “For Windows, holding down the Ctrl or Shift key while clicking on the refresh button works as does pressing Ctrl-F5. For Macintosh and all other operating systems, holding down the Shift key while clicking on the refresh button works as does pressing Command-Shift-R. Additionally, on Macintosh, holding down the Option or Command key while clicking on the Refresh button appears to work as well.”

    Plugin Author Robert Windisch
    Member

    @nullbyte

    We have released version 3.0.12 which will fix this issue. Please use the current version.

    regards,
    Robert

    myopicjazz
    Member

    @myopicjazz

    I renamed the backwpup folder, removed the folder, tried renaming the plugins folder, stood and one leg and rubbed my belly. I was either stuck in the redirect loop or getting a server error. I wound up deleting and restoring my blog using the latest backwpup backup. Worked perfectly.

    KroniK907
    Member

    @kronik907

    Just updated to the new version and got the redirect loop. Checked backwpup.php and the new code is there… Tried a Hard refresh… still nothing. Removing my plugin folder… will report back with solution.

    KroniK907
    Member

    @kronik907

    Well. Deleting the backwpup folder removed the redirect loop. Tried to re-install and I can find no way to set up the backups at all. Only the Dashboard tab and about tab. There seems to be no “First Steps” box or any way to use this plugin now… I am dissapoint.

    KroniK907
    Member

    @kronik907

    Uninstalled the backwpup plugin from the plugins page. Then re-installed. This fixed my problem. Also installed Humility which will save me so much time… seriously.

    Sonja
    Participant

    @summit

    We deactivated & removed 3.0.11, cleared cookies, reinstalled 3.0.12 and are still getting a redirect error while trying to update settings.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘3.0.11 gives redirect error…’ is closed to new replies.