Support » Installing WordPress » 3.01 Update – Failed and stuck! PLEASE Fix your upgrade!

  • dimeco

    (@dimeco)


    While I appreciate the work done to keep WP free, I have to say, if you’re going to roll out an upgrade – why on earth would it not be tested to make sure it actually WORKS for people??

    My site is now stuck in Maintenance mode – whatever that is!

    Here’s the error that happened:

    Downloading update from http://wordpress.org/wordpress-3.0.1.zip…

    Unpacking the update…

    Verifying the unpacked files…

    Installing the latest version…

    Could not copy file.: /public_html/wp-admin/css/theme-editor.dev.css

    Installation Failed

    for the record – this is a WP Mu site, and I was JUST about to launch!!

    Help?!

    AJ

Viewing 15 replies - 16 through 30 (of 90 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    The drink may not be a bad idea, but let’s try a couple of things first. THEN go drink. 🙂

    Start with the easy part, do you have a backup of your WordPress files? If so, then restore wp-config.php. Easy peezy.

    If you don’t have a backup (sounds like you don’t) them backup your files and database right now. That’s critical.

    http://codex.wordpress.org/WordPress_Backups
    http://codex.wordpress.org/Backing_Up_Your_Database

    Get ready to restore so you can return to where you are right now. This is in case more Bad Things happen.

    http://codex.wordpress.org/Restoring_Your_Database_From_Backup

    Now rename wp-config.php to wp-config-SAVE.php and copy wp-config-sample.php to wp-config.php and put in your DB_NAME, DB_USER, and DB_PASSWORD. Change DB_HOST if you need to.

    Did that get you back to be able to admin your blog? I’m suggesting this in case the problem is in your wp-config.php file. If that doesn’t get you back, let us know and more suggestions will be coming.

    shootingparrots

    (@shootingparrots)

    I do have a copy of the files on my hard disk and I have updated it. I used to get a db back-up emailed to me twice a day, but that stopped on 17 July.

    I think I’ve back up my db from my server and have the import option.

    Finally, I tried the changes to the wp-config file and got this message when trying to acces the dashboard and the site:

    Fatal error: Call to undefined method wpdb::tables() in /mnt/web9/40/39/51978039/htdocs/blog/wp-includes/functions.php on line 1839

    bonniekirk

    (@bonniekirk)

    The upgrade also failed for me, on 2 installations, for 2 different reasons, both running on the same shared host. NEITHER site is stuck in maintenance mode.

    Like for dimeco, the upgrade failled on the first site because it could not copy theme-editor.dev.css.

    The second failed because it “Could not create directory.: /public_html”.

    After the first upgrade failed, I thought it would either be a permissions issue, or a function of the theme I’m using. Now I’m just baffled. Since the upgrade is for minor issues, I will probably wait to revisit this upgrade until more experienced people sort this out.

    cowgirlup

    (@cowgirlup)

    I got the very same /public_html message.
    Jan, can you walk me through fixing this please?

    Thanks

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    “Call to undefined method” basically means you’re missing files somehow.

    Download a fresh copy of WP, install the files onto the system manually. Via FTP or what have you.

    Remember, a manual upgrade is always an option. All you really have to do to manually upgrade is to put the new files on your server, overwriting the old files, and not touching the configuration files like wp-config.php and such.

    shootingparrots

    (@shootingparrots)

    I assume from this that I’m going to have to manually install WP as described if I’m to get my site working again. When you say “not touching the configuration files like wp-config.php and such” exactly what is the ‘such’ that I shouldn’t touch?

    The original automatic install was easy enough, but all this WP3 stuff is a bit of a nightmare.

    change_magic

    (@change_magic)

    This is my 3.01 error:

    Warning: copy(/home/*****/public_html/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /home/*****/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    As there seem to be many problems with installing this version I’m sticking with 3.0 unless anyone has a *really* easy fix for the above. I’m focused on creating content for my site. (Unless there’s a priority security reason for installing the lasted WP version).

    patdundee

    (@patdundee)

    Hi Guys

    I am also gett Could not create directory.: /www

    Does anyone know the correct permissions for each of the WP folders and sub folders for WP

    ?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    When you say “not touching the configuration files like wp-config.php and such” exactly what is the ‘such’ that I shouldn’t touch?

    Any changes you’ve made to the overall system, basically. Your plugins. Your themes. Your wp-config.php file.

    MSWD

    (@mswd)

    change_magic – did you find a fix. I am having the same exact issue. Please let me know what you found- thanks

    webactif

    (@webactif)

    I too have this bug …
    I havnt quite worked a way to fix it BUT to get your site back if its stuck on site maintenance is to delete whats in the update folder in wp-content.
    This should bring things back to what they were.

    I think as this is becoming a common issue i’ll wait for next WP ver to start updating all my sites !!!

    Tanshaydar

    (@tanshaydar)

    Hi,
    I just uploaded new package files to my server. After everything uploaded, I tried to upgrade the database, but it gave an error (Fatal error: Call to undefined function is_multisite() in /…/wp-includes/wp-db.php on line 505).

    Now it’s stuck. I can’t do anything. I tried to re-upload every file but it doesn’t work. My blog still gives same error and I can’t reach anything.

    Tanshaydar

    (@tanshaydar)

    Well I solved the problem.

    riddle

    (@riddle)

    I’d like to get back to the original poster’s point: 3.0.1 automatic upgrades are too unreliable for the very WP admins who most need one-click upgrades.

    ipstenu’s reply (“This is a problem with your server setup, most likely, not WP. The most likely reason would be that your PHP setup doesn’t like the way WP 3.0.1 is unzipping and copying files.”) misses the point. If there are common PHP configurations under which the automatic upgrade won’t work, then at a minimum the upgrade script should test for them before breaking the site.

Viewing 15 replies - 16 through 30 (of 90 total)
  • The topic ‘3.01 Update – Failed and stuck! PLEASE Fix your upgrade!’ is closed to new replies.