Support » Plugin: 301 Redirects - Easy Redirect Manager » 301 Redirect doesn’t work

  • Resolved Douglas47

    (@douglas47)


    My website is yoga-space.org, but it resolves to: http://yogaconn.ehost.com/wordpress/.

    Because I want to offer my students the ability to pay for classes with credit cards, I needed a secure network. I learned that the servers (ns1.ehost.com and ns2.ehost.com) had SSL, and that it was apparently already installed on my website. So I went into the general settings and changed both my WordPress Address (URL) and my Site Address (URL) to https://yogaconn.ehost.com/wordpress/. Fine. That made the WooCommerce plugin happy. I even did an online test, and it said that the TSL Certificate for yoga-space.org was correctly installed. When I click on my old website shortcut on my desktop it takes me to the secure version.

    But unless I specifically input https://etc. the browser will resolve to the http:// unsecured network. When I do input https:// etc., it shows up as a secured network. Hence my installation of 301 redirect. I currently have 3 redirects for: http://www.yoga-space.org, http://www.yoga-space.org, and http://yogaconn.ehost.com/wordpress/. All of them I have being redirected to https://yogaconn.ehost.com/wordpress.

    And…none of them work. When I input any one of them in my browser, they all bring me to the unsecure http site. I tried refreshing the cache, but no luck.

    Any suggestions?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Actually, now that I try out the links on my message, above, NONE of them take me to the secure site. Only my shortcut on my desktop, which I created years ago. That one takes me to the https:// site.

    @douglas47 I think what You need is the other plugin we have to force ssl. This is to inform, for example, google that url example.com/AB is now example.com/AC

    For what you need just use our plugin: https://wordpress.org/plugins/wp-force-ssl/

    Before installing this plugin please put back again your wordpress and site url back to http. The plugin will take care of everything for you.

    Plugin Author WebFactory

    (@webfactory)

    Hi, there’s a lot going on here. My colleague will have a more in-depth look but 99% that at least some of the issues you’re having will not be solvable by this plugin but rather something like https://wordpress.org/plugins/wp-force-ssl/

    Hi Manuel. First, thanks for your reply. So I went into my general settings and set my wordpress and site url back to http. Then I installed the plugin wp-force-ssl.

    [Sigh] No luck. When I click on Test site’s SSL certificate, it comes back with the message, “An undocumented error has occurred. Please refresh the page and try again.”

    I refresh the page and it gives the same result. Maybe I should deactivate the 301-redirect?

    After trying a few more things, I saw a message that said to make sure your wordpress and site url are set to https. So I changed them back. When I did that and then ran “Test Site’s SSL Certificate”, the message came back: “Test completed successfully. Valid SSL Certificate found.”

    But every combination of yoga space that I put into my browser still produces http, not https. And still my shortcut on my desktop takes me to the secure site.

    AND NOW I THINK I FOUND THE PROBLEM! The desktop shortcut came from Internet Explorer. When I use that as my browser and use any variation, it takes me to the secure site. When I use Google Chrome, it doesn’t. I’m not sure how to fix that, but maybe you have a suggestion?

    @douglas47 did you disable/uninstall 301? You don’t need it when using the force ssl.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.