Support » Installation » 3.0 upgrade now my New Post links all show a blank page

3.0 upgrade now my New Post links all show a blank page

  • Just updated to 3.o and installed F2 theme. But any link for New Posts loads a blank page. I cant add new posts! Help.
    Tried an alternate theme, did not help
    Any suggestions please

Viewing 15 replies - 16 through 30 (of 32 total)
  • While I am backing up, and before installing, could this be a problem with creating new docs? Or should the dialog appear anyway?

    Sorry, I’m not sure I understand what you’re asking.

    I am having the same issue.

    I have increased memory in wp-config, disabled all plugins, switched to default theme, replaced wp-includes and wp-admin. I am getting no where. Do we have any other suggestions? This upgrade has really put me in a bind.


    Still struggling too
    I have now manually removed all files except
    .htaccess, wp-config.php and wp-content (I even removed the plugin folder and replaced that)

    Nothing has changed, still get a blank page when I try to create a new post or a new page.

    The possible problems are getting shorter. I tried to create a new user, but cant do that with same email address. Is there a way around that?

    Any other ideas? Please help someone this is killing me!

    Just noticed on another thread that this issue seems to affect only Earthlink hosted blogs.

    I am also using earthlink to host.

    I am still wondering if there is a permissions problem somewhere – any ideas?

    Just had this from earthlink
    “It seems that the latest version of WordPress has some incompatibility issues with our server.”
    They suggest going back to 2.9.2

    “It seems that the latest version of WordPress has some incompatibility issues with our server.”

    PHP, I’ll bet :/

    There is another thread running for this issue: http://wordpress.org/support/topic/414105?replies=7#post-1572310

    I’ll post this here as well, if you know what 3.0 requires in terms of PHP support, please let us know if one of these needs to be activated and we can all bug Earthlink like crazy: http://www.maximludwig.com/phpinfo.php


    Honestly, it’s just PHP 4.3 (see http://wordpress.org/about/requirements/ for the requirements). PHP 5 is better, in general, but really, this sounds like they have permissions on PHP set up in some funky way, and they’re not apparently willing to debug.

    If this was a COMMON issue, more people than just Earthlink users would be running into it.

    I’d ask Earthlink if there’s anything special you need to do to run PHP 5, and if they have an intention of looking into why THEIR install doesn’t like WP 3.0 when most every other host does.

    And if they don’t want to help you, take your money away from them.

    Having same issue here.

    In my case it only occurs after activating a child theme of Twentyten. Every “Publish”, “Save changes” results in a blank screen. The child theme is dead simple, so I don’t quite understand how it could cause this issue.

    • PHP version is 5.2.5
    • Memory limit is set to 64MB

    Site is part of a WP 3.0 MU setup, I’m now checking of one of the ‘network’ plugins could cause this issue.

    wpcubus – Are you also on Earthlink?

    I just spoke to Earthlink tech support. They told me they are putting their “engineers” on it. It will take 48-72 hours just to get an answer back. I’m switching hosts. Earthlink is over-priced anyway. Found a great deal here: http://www.hostgator.com/resellers.shtml

    Moderator Andrew Nacin


    Lead Developer

    For Earthlink issues with creating a post, see: http://wordpress.org/support/topic/411708?replies=6#post-1578338

    Earthlink just fixed the problem for me. They have also given me a link to the fix for others. they wrote

    “After working with WordPress, a bug in the 3.0 release was discovered which prevented it from working properly with PHP 5.0. A minor code modification was made to correct this, which could be found here:

    http://core.trac.wordpress.org/changeset/15359 <http://core.trac.wordpress.org/changeset/15359&gt; “

    There will be a change in the next version of wordprss to avoid the problem. Thanks everyone 🙂

    Moderator Andrew Nacin


    Lead Developer

    It’d be nice if they also mentioned your site was running on a buggy, five-year-old version of PHP 5, but hey, you pick your battles. 🙂

    @ipstenu sorry for the late reply: No, site isn’t hosted on Earthlink.

    The issue in my case is caused by the child theme’s functions.php file. If I delete it from the child theme folder everything is working fine.

    Strange thing is that even a empty functions.php file is causing pages to turn blank.

    I used this child theme on another server, in a normal (non MU) setup without any issues.

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘3.0 upgrade now my New Post links all show a blank page’ is closed to new replies.