WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 3.0 Plugin Upgrade Bug? Could Not Create Directory

[Resolved] 3.0 Plugin Upgrade Bug? Could Not Create Directory

  • eddihughes
    Member

    @eddihughes

    Upgraded to 3.0 today. After upgrade, went to upgrade plugins and got caught up on a bug.

    View post on imgur.com

    Dashboard -> Updates -> Select all plugins. It asks me for FTP information, punch it in, select FTPS and go.

    An error occured while updating podPress: Could not create directory. /public_html.

    I get these errors for multiple plugins.

    View post on imgur.com

Viewing 15 replies - 31 through 45 (of 99 total)
  • I tried the “delete and CHMOD the upgrade folder” fix and it didn’t work for me, so here’s what I did:

    1. Delete the upgrade folder
    2. CHMOD the wp-content folder to 777
    3. Run auto-updater through admin again

    This will allow admin to write the upgrade folder to the wp-content folder and install…or at least it worked in my case!

    Reine Marge
    Member

    @reine-marge

    Hmm… ledfrog I tried what you suggest and alas it still didn’t work … I am beginning to wonder if I should just bite the bullet and try a manual install despite my lack of techie know how?

    freelancemom
    Member

    @freelancemom

    VictoryTrader — that sounds logical. Any idea how much the upload limit needs to be increased to? I’ve changed mine to 8M and am still getting errors :-/

    Sue
    Member

    @kadian

    I have both changed my php limits (to unlimited) and permissions on the upgrade folder. I still can not update one of my sites from 3.0 to 3.0.1. Even the manual update option does not work.

    Any additional suggestions?

    eschaa00
    Member

    @eschaa00

    A bit of a techie response, but many web sites run PHP (when under *NIX) as the user nobody or some user other than yours. So if you install WP or a module directly (as you) then later try to update via the WP admin area, the file ownerships are wrong.

    A chmod 777 wp-content is not enough of a fix because the folders and files beneath may still be wrong. This is also a security concern.

    And “yes”, the PHP upload limit for your host must be at least as large as the update you wish to upload. PHP has a post limit and an upload limit … and if your host cannot manage to set reasonable limits then consider hosting with 10types.com. (I did not start this response to promote, but it now strikes me that any host still deploying with a 2mb upload default does not expect their customers to do much at all.)

    I think the “Could not create directory ./public_html” (or the like) is misleading because the issue is likely the wp-content/plugins or wp-content/upgrade folders.

    Any host admin with root privileges should be able to fix the permissions / ownerships on your WP files. For WP deployments where I don’t have root, I:

    1. Make certain that under wp-content, the cache, plugins, themes, upgrade, and uploads directories are chmod 777.
    2. Make certain that the wp-content directory is chmod 755 or 750 (depending on your host) … do not make this world writeable!

    If you attempt to upgrade a plugin and still get the “Could not create …” error after the 2 steps above, this means that file ownership of the plugins is wrong. To fix, use whatever file browser is available on your host to traverse to the wp-content/plugins directory and then remove the folder holding the older version of the plugin … and then use the WP admin to install the newer version.

    As always … it’s a good idea to make backups of your files before attempting changes.

    kvcindia
    Member

    @kvcindia

    Amazing, don;t know the reason, but it worked in that way.

    Deleted upgrade folder >> created again >> given 777
    and it worked.

    Before that it was not working even I had all my folders with 777 blog/wp-content/upgrade.

    Ok, At last it worked

    kvcindia
    Member

    @kvcindia

    Here’s something new !
    It fixed and update the old plug in but can’t install new plug in always says, “The plugin does not have a valid header.”.

    Any comment ?

    Steve@316
    Member

    @steve316

    @kvcindia – May I suggest another/new thread for that particular problem? Still working on my “Could not create directory.” error

    Thx

    Steve@316
    Member

    @steve316

    I’m getting the same error messages, tried to upload an image and add a plugin:

    ““imagename.jpg” has failed to upload due to an error
    Unable to create directory /wp-content/uploads. Is its parent directory writable by the server?”

    “Could not create directory. /httpdocs/wp-content/upgrade”

    Tried everything suggested so far, except waiting on server administrator change your PHP upload limit.

    Steve

    Steve@316
    Member

    @steve316

    Update: It seems I have the upload image problem solved. I tried changing the permissions on the upload l=folder and it worked this time.

    But! Still getting the “Could not create directory. /httpdocs/wp-content/upgrade/,… Error

    Does anyone have an answer/solution?

    Steve@316
    Member

    @steve316

    Update: It seems we have solved the problem. I modified the ownership of the uploads directory to apache:apache.

    Since you’re using a web interface to upload and work with the file system, the web interface runs as the apache user, not your ftp user.

    lldanj
    Member

    @lldanj

    CHMOD 777 for the Upgrade folder worked for me.

    guguwpblog
    Member

    @guguwpblog

    delete, recreate and CHMOD 777 for the Upgrade folder worked for me.

    richardobbo
    Member

    @richardobbo

    I just upgraded to 3.0.1 today. And I am having the problem which many here have mentioned which is I am unable to auto install plugins or themes. When I click install, all I get is this message:

    “Installing Plugin: Contact Form 7 2.3.1
    Downloading install package from http://downloads.wordpress.org/plugin/contact-form-7.2.3.1.zip

    I have tried just about every solution in this and other threads except that I have not tried to delete the upgrade folder. And still nothing has worked. Not being a techie I found it curious that the folder was empty. Should it be? If not, what should the contents be? Any other thoughts on how to fix this issue?

    esmi
    Forum Moderator

    @esmi

    Try adding AddType x-mapp-php5 .php to the top of your WordPress .htaccess file.

Viewing 15 replies - 31 through 45 (of 99 total)
  • The topic ‘[Resolved] 3.0 Plugin Upgrade Bug? Could Not Create Directory’ is closed to new replies.