WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 3.0 Plugin Upgrade Bug? Could Not Create Directory

[Resolved] 3.0 Plugin Upgrade Bug? Could Not Create Directory

  • eddihughes
    Member

    @eddihughes

    Upgraded to 3.0 today. After upgrade, went to upgrade plugins and got caught up on a bug.

    View post on imgur.com

    Dashboard -> Updates -> Select all plugins. It asks me for FTP information, punch it in, select FTPS and go.

    An error occured while updating podPress: Could not create directory. /public_html.

    I get these errors for multiple plugins.

    View post on imgur.com

Viewing 15 replies - 16 through 30 (of 99 total)
  • I have three sites, that I run and maintain. Till now, I was deleting the specific folder of the upgrade plugin, uploading the zip and extracting it. From Dashboard, re-enabling it. Bit tidiouse for the the connection speed I work with. It worked always.

    However I am going to try the above solution of deleting the upgrade folder and recreating and changing permission to 777 and see how it goes. I will post here if that works.

    Ok good news. Out of 7 required to upgrade,

    One failed, saying could not remove the older version.

    Could not remove the old plugin..

    One more failed with the same error

    Could not create directory. /public_html.

    Rest 5 of them worked fine. No problems.

    So I say the solution works. Thanks so much lyndasu

    rockinfree
    Member

    @rockinfree

    Yep, deleting the folder & recreating it worked for me too. Thanks!

    Reine Marge
    Member

    @reine-marge

    Hmm… I did the automatic update and it partially worked, that is to say the dashboard looks different and it does say I am using version 3.0, but the problem is it also says an update failed and needs to be run again.

    All my themes and plugins are up to date and working fine. When I try to run the automatic WordPress core update I get an error message saying:
    Could not create directory.: /public_html

    This is all very confusing. I have used cpanel/Fantastico Deluxe to update WordPress but it is not showing version 3.0 as an option.

    Does anyone have any ideas?

    Hmmm…the proposed solution of deleting the “upgrade” folder and then recreating it and assigning “777” permissions worked for me a few days ago, but now I get the same error when trying to install another plugin.

    I do not want to perform this task each time I need to install a plugin 🙂

    Seems to be a larger issue at play. Any other solutions out there?

    Thanks – Scott

    @reine Marge – My host has informed me there is a CPanel issue with WordPress file ownership. I will try to explain this how I understand it, but if I am incorrect, someone please advise:
    At times, file ownership is assigned to “Nobody” within Cpanel (not sure if this is for Fantastico installs only or if manual installs have this too). So when you run the core update, you do not have permission since “Nobody” is assigned permission.

    The solution has to do with the hosting server setup (suPHP and PHPsuExec), which I do not have the expertise to explain.

    It’s frustrating, and from what I am told, not an easy fix. Hope someone out there might have a solution 🙂

    Befashionlike
    Member

    @befashionlike

    sorry for my bad english, i’m french

    I get the same error today,when a try to delete my “Upgrate” directory i see this following error message “Disk quota exceeded” i delete some file, and now evrything is ok.

    darkferrett
    Member

    @darkferrett

    @sbernado

    I installed wordpress using fantastico under cpanel and the deleting and remakeing of the upgrade folder with 777 permissions seemed to work for me too. The only thing I would ask is – are we safe creating folders with 777 permissions, are these not security risks (sorry not too up on all this if this seems a silly question)

    Same problem but haven’t solve it yet. I’ve tried to recreate the upgrade & set to 777, but still error occurs. Then I tried to manually upgrade it but after, the notice shows: “An automated WordPress update has failed to complete – please attempt the update again now.”

    Please help. Thank you in advance.

    mrjoker
    Member

    @mrjoker-1

    thank you so much, problem resolved, but still waiting for the reason

    Reine Marge
    Member

    @reine-marge

    OK, so Fantastico deluxe finally had version 3.0 so I updated that way … and I still get the same notice/error message as jaksalee, and I also get the ‘Could not create directory. /public_html’ when trying to update themes.

    m3Rlin
    Participant

    @m3rlin

    Wow! I don’t know why it would matter to remove the wp-content folder first (I tried the chmod 777 many times and that didn’t solve the problem) but it worked! Thanks!

    Thanks folks, deleting the upgrade folder and recreating it/ CHMOD 777 worked for me. I was going crazy trying to figure this out.

    Didnt work for me. Upgrading from .0 to .01, I even went through every directory and changed them to 777 to see if that would work, no luck so I changed them all back. On another site, I just upgraded from 2.9 to .01 with out a problem. This sux, Ill have to back everything up and try a manual install.

    victorytrader
    Member

    @victorytrader

    Figured it out…

    You need to have your server administrator change your PHP upload limit. Right now with CPanel it is automatically set at 2MB limit and so when it goes to update WP 3 it can’t complete and keeps the install files in the folder… hence why you cannot install anything else. This solution worked for me.

Viewing 15 replies - 16 through 30 (of 99 total)
  • The topic ‘[Resolved] 3.0 Plugin Upgrade Bug? Could Not Create Directory’ is closed to new replies.