Support » Alpha/Beta/RC » 3.0 Problem

  • WP 3.0 Using the Twenty Ten theme:
    I was creating a Page and saved as draft. In a bit I published it. I had forgotten to in Attributes to make it Page 4 so it was set to 0. It was displaying as my first page in the Navigation. I edited and made it Page 4. Now when I click on the page in the navigation bar it gives me this:

    Apologies, but the page you requested could not be found. Perhaps searching will help.

    When I am editing the Page and Preview Changes I get this:

    By | Published
    This entry was posted in Uncategorized. Bookmark the permalink. Follow any comments here with the RSS feed for this post. Both comments and trackbacks are currently closed.

    The page is there, I’ve not changed the permalink or anything else and now I can’t get it to display.

    A similar thing occurred with this same page when I started off. I created a .png file of a PDF and wanted that to be the page. I could never preview or view it always got this:

    Apologies, but the page you requested could not be found. Perhaps searching will help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I am currently unable to duplicate this bug. Are you using the default ‘menu’ that is made when you don’t have one made?

    What happens if you create the structure you want with the appearance -> menu’s?

    Is it still in draft mode when you get the 404?

    Yes, using the default Menu (navigation).
    I didn’t try the menu feature.
    I had published the page and got the error.

    I’ve worked and worked with this page. I want my page called ‘Fee Schedule’. I set up another page called ‘Fee Schedule Test’ and copied contents over. Published and was good.
    Delete permanently the orig. page ‘Fee Schedule’.
    Renamed the test page ‘Fee Schedule’ and get the error that the page is not there.
    I went in and changed the page title and permalink to ‘McCarthys Fee Schedule’ and published and it is there fine.

    Apparently it doesn’t let me use ‘Fee Schedule’ for some strange reason. Perhaps it sees the ‘Fee’ as html code instead of the word ‘fee’.

    Mark Jaquith


    WordPress Lead Dev

    One possibility is that your host is using something called mod_security. It has a configurable blacklist of phrases that can trigger strange issues like this.

    Also, if you’re using a WP 3.0 version older than 3.0-RC1 (such as one of the betas), please update to 3.0-RC1 and test it again.

    Also (2), if you have any 404 or redirection plugins enabled, try disabling those.

    I upgraded to 3.0 RC1.
    I had to set up the menu to get it back to a horizontal navigation bar.
    So I changed the navigation to read ‘Fee Schedule’ and left the page titled ‘McCarthy’s Fee Schedule’. When I refreshed the page it displayed but then I decided to change the page title to read ‘S. M. McCarthy’s Fee Schedule’ but left the navigation to read ‘Fee Schedule’. When I refreshed the page I got the page not found error.
    Went back in to the Menus and put ‘McCarthy’s’ back in front of ‘Fee Schedule’, refreshed and it was fine then.
    For some strange reason it won’t let me just have ‘Fee Schedule’ as the page title and in the navigation bar.

    I host with BlueHost and they are not doing any mod_security that would affect this. They did graciously upgrade the site to 3.0 RC1 for me though.

    Here is the URL:


    I’m using 3.0 beta 2. How can I update to 3.0 RC1 without doing a complete new install and risk losing all my data and customizations?
    Does anyone know if there is any difference in the DB structure between beta2 and RC1?

    Thank you kindly for your reply!

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    AdmireNL, you should make a new post for that, though the answer is “Same way you always upgrade WP without losing data or customizations.”

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘3.0 Problem’ is closed to new replies.