Getting "Could not create directory. /public_html" updating plugin with 3.0 (6 posts)

  1. denede19
    Posted 6 years ago #

    Downloading install package from http://downloads.wordpress.org/plugin/stream-video-player.1.2.0.zip…

    Unpacking the package…

    Could not create directory. /public_html

    i get this when try to auto-install
    thing there's a bug in source code ..

  2. hamidoo07
    Posted 5 years ago #

    i'm expriencing the some problems after upgrading to 3

  3. meaganleigh
    Posted 5 years ago #

    Hi guys, i've been having trouble with this for a while and have given up! I get the same error Could not create directory. /public_html when trying to install the backup program.

    I do not understand how to change the permissions to 777. I use ClassicFTP on a MAC OSX and i have searched and searched on the FTP client to find where it gives you the option to do this.

    I even emailed the software company that makes ClassicFTP to ask them because I couldn't find anything on any forums about it, everyone just acts like its so obvious! They stated that I have to change the permission on my actual hard-drive, not through the FTP client. But I don't know where any of the WP folders are located on my computer... I thought they were created through the FTP client and not on my hard-drive.

    Can someone PLEASE help me, I'm pulling my hair out!! Baby steps please!

  4. pixelrage
    Posted 5 years ago #

    It doesn't matter. Even with 777, you still get the error. WordPress fail...I'm starting to get a little upset with WP, now I can no longer auto upgrade either WP nor plugins because of this error.

    Meagan - just right click the file and look for "permissions" and change the CHMOD number...it's that simple. If ClassicFTP doesn't do it, just use Filezilla - it's free & better.

  5. surfbits
    Posted 5 years ago #

    I am still getting this error in one of my WP installs, all the other work and the layout is the same in them all.. Any ideas on why I'm seeing this when doing ANY auto-updates at all?

  6. surfbits
    Posted 5 years ago #

    I solved the problem. The /wp-content/upgrade directory needs to have permissions set to 777, they were not set correctly. I made the change and everything updates just fine.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.