Support » Alpha/Beta/RC » 3.0 Buddypress eShop Error

  • Resolved justbishop


    I really suck at figuring out errors. Any help or direction is appreciated!

    I’m running the 3.0 beta (multisite enabled) with the latest Buddypress and eShop. I haven’t fully tested for eShop functionality yet, but the first stumbling block I’m running into is the following error on my blog directory page:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/*****/public_html/wp-content/themes/bp-child/blogs/blogs-loop.php:3) in /home/soirifqo/public_html/wp-content/plugins/eshop/eshop.php on line 876

    It doesn’t seem to be affecting function at all (search and everything there is working just fine), but it just looks ugly. Is there a line somewhere that I need to delete?

    ETA: seems to be throwing the same error on all pages that include a search box and/or pulldown menu for filtering.

Viewing 11 replies - 1 through 11 (of 11 total)
  • well I don’t support buddypress, and I’d be surprised if it worked with out errors.

    sessions are needed for eShop, so it isn’t a case of just removing it.

    But have you checked that the themes/bp-child/blogs/blogs-loop.php doesn’t have whitespace in it?

    Where would whitespace be bad? Am I looking at the very beginning/end?

    I disabled eshop and everything is fine now, but I really need the plugin for the whole concept of the site to work!

    Thanks for helping me out!!

    The white space would be OUTSIDE the <?php ... ?> marks on the top and bottom of the file.

    Hm. I just checked and there was a blank line at the very end of blogs-loop.php. I’m in the process of updating to the latest nightly build of 3.0, but after that I’m going to edit/upload blogs-loop.php and see if that helps.

    Thanks again!!

    Well, unfortunately, that didn’t help 🙁

    Maybe blogs-loop.php is calling something else that’s creating whitespace”

    Here are the first few lines from the top and bottom of blogs-loop.php:

    <?php /* Querystring is set via AJAX in _inc/ajax.php - bp_dtheme_object_filter() */ ?>
    <?php do_action( 'bp_before_blogs_loop' ) ?>
    <?php if ( bp_has_blogs( bp_ajax_querystring( 'blogs' ) ) ) : ?>
    <?php endif; ?>
    <?php do_action( 'bp_after_blogs_loop' ) ?>

    Putting up the standard FAQ link just cause:

    The error is on like 3 of blogs-loop.php though. That’s what the error code means.

    I’m assuming bp-child is your child theme of bp-default or such. Your lines match the ones in bp-default, so the error’s that this <?php do_action( 'bp_before_blogs_loop' ) ?> doesn’t like the plugin. Or however we want to say it.

    I don’t know off the top of my head how to solve it though.

    Are you using MultiSite? If so, did you install the plugin network wide? If so, try JUST activating it for the one blog. That’s as far as I can think before lunch.

    Yep, I’m using a child theme, and my line 3 of blogs-loop.php is the same as the default. I just tried enabling the plugin on the main site (which is the only one that exists at the moment), and that didn’t seem to help. I actually don’t need it on my main site. Is there any way to have it activated for them and NOT on the main site?

    Thanks so much for taking the time to look at this, guys! I have the issue xposted at the BP forums as well, so maybe something will come of that that gets us a step closer to figuring it out. In the meantime, I have lots of other things I can work on and hope that we can resolve this before I’m done with all of it 🙂

    hmm have a look at line 458 of eshop.php
    you could try changing that to:

    May solve it by running that function a little earlier.


    That seems to have fixed it! I still need to do actual functionality testing, but the errors seem to be gone!

    excellent, I’ll that in now for the next version before I forget, probably worth it for that one anyway.


Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘3.0 Buddypress eShop Error’ is closed to new replies.