Support » Plugin: Internal Links Manager » 3 problems

  • Resolved Gilou24

    (@gilou24)


    Hello,
    I installed Internal Links Manager a few days ago and I am very satisfied with it.
    There are, however, a few issues:
    1) The loading time of archive or research pages was extremely long.
    I solved the problem with Freesool Deactivate Plugins (by deactivating Internal Link Manager for this type of content). I think this may help some users … But it would be better if your plugin did it itself (archives or searches don’t need internal links …).
    2) Sometimes, when I enter too many keywords, or the keywords are too long (I’m not sure if it’s one or the other reason), the system doesn’t save any keywords. . without an error being reported. Is there a keyword limit for an internal link? Or a character limit for a keyword?
    3) the statistics do not work … if I check “Do not track link clicks when logged in”, there is no recorded click … and if I uncheck this box, only my clicks are taken. account. I would like to point out that there are several thousand visitors per day on my website, and already many internal links generated by your plugin. Maybe a problem with the cache system I’m using (Lite Speed ​​Cache).
    About statistics, I suggest a possible improvement (or not?): the number of internal links pointing to a given post (in order to quickly see if a post is well relayed on the rest of the website).
    Thank you.
    Regards,
    Gilles

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author webraketen

    (@webraketen)

    Hey Gilles,

    thanks for your feedback!

    1) We have not yet encountered this issue. But I think we can exclude archives from the search results
    2) This seems like a bug. Can you give me an example with which keyword(s) this issue happens? Then I can reproduce this bug and fix it.
    3) Could you deactivate your caching plugin for some testing to check, if the plugin causes this issue?

    Thanks a lot!

    Thread Starter Gilou24

    (@gilou24)

    Hi ,
    1) ok …
    2) all entered keywords disappear when the bug occurs … so it is very difficult to understand the reason. But when it does happen again, I’ll try to hold it back and pass it on to you.
    3) I disabled the cache plugin to test, but there is still no recorded click (I tested on another browser as well as with another device, but nothing …)
    Regards,
    Gilles

    Plugin Author webraketen

    (@webraketen)

    Hi Gilles,

    2) That would be awesome. Meanwhile we’ll try to reproduce that too.
    3) We will check that. Maybe I have an idea…

    Thanks

    Thread Starter Gilou24

    (@gilou24)

    Hi,

    The problem just happened again.

    There were 6 keywords (in french): “culture de pommes de terre sous paille”, “culture de pommes de terre sous paillis”, “culture de pommes de terre sur gazon”, “cultiver les pommes de terre sous paille”, “cultiver les pommes de terre sous paillis”, “cultiver les pommes de terre sur gazon”
    It was ok…

    I added 3:”pommes de terre sous paille”, “pommes de terre sous paillis” and “pommes de terre sur gazon”.

    And, as you can see here https://i.imgur.com/puHiBuT.jpeg, the keywords have been removed …

    There are other internal links with more keywords and longer keywords … which are okay …
    There are also no special characters …
    It is therefore incomprehensible.

    Regards,
    Gilles

    Plugin Author webraketen

    (@webraketen)

    Hi Gilles,

    that’s perfect, thanks! I can reproduce the issue with this usecase. We will have a look at that and try to fix this with the next update.

    Thanks for your help,
    Bernd

    Plugin Author webraketen

    (@webraketen)

    @gilou24 2+3 should be fixed with the latest update (2.3.0) Could you check that? Thanks!

    Thread Starter Gilou24

    (@gilou24)

    Hello,
    I just did a test with the same keywords as before.
    Everything has been recorded. So, a priori, it works.
    Thank you.
    If the problem happened again, I would let you know.
    Cordially,
    Gilles

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘3 problems’ is closed to new replies.