Support » Plugin: WP Google Maps » 3 dots keeps circling

  • Resolved webitman

    (@webitman)


    Since the update to 8.12 the center displays 3 dots circling in a loop.
    Rolling back to 8.0.31 and flushing the cache the marker shows up.
    I can’t find the solution to this problem.
    Please assist, because it happens on all my websites.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author NickDuncan

    (@nickduncan)

    @webitman please go to maps -> settings -> advanced settings -> and select the option at the bottom that says “disable compressed paths”

    Does this help?

    Thread Starter webitman

    (@webitman)

    Thanks for the quick reaction. I tried all 3 options with and without cloudflare and no difference.
    It looks like it has to do with the marker.
    Installed with WordPress 5.6 and health is OK, so non issues except this one.
    CSS no display marker ? but how ?

    Thread Starter webitman

    (@webitman)

    After this CSS edit the 3 dots are gone, but it’s not the solution.
    .wpgmza-preloader {
    pointer-events: none;
    z-index: 10000000000;
    display: inline-block;
    position: relative;
    width: 64px;
    height: 64px;
    /* ================== 3 dots are gone ============> position: absolute; */
    top: 50%;
    left: 50%;
    transform: translate(-50%, -50%);
    }

    Hey Webitman,

    I have the same issue as you

    Hi all,
    I think this error is related to the issue:

    
    Uncaught Error: SyntaxError: Unexpected token < in JSON at position 0
        at Object.params.error (wp-google-maps.combined.js:7750)
        at i (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:2)
        at Object.fireWith [as rejectWith] (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:2)
        at x (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:4)
        at XMLHttpRequest.c (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.3:4)
    

    The above error in js has disappeared when I have fixed notice:

    Deprecated: Unparenthesizeda ? b : c ? d : eis deprecated. Use either(a ? b : c) ? d : eora ? b : (c ? d : e)in /opt/lampp/htdocs/viveubeda-v5/wp-content/plugins/wp-google-maps/includes/class.rest-api.php on line 668

    Changed line 668:
    $id = (isset($m[3]) ? ltrim($m[3], '/') : isset($m[2]) ? ltrim($m[2], '/') : -1);

    to this:
    $id = ( isset($m[3]) ? ltrim($m[3], '/') : (isset($m[2]) ? ltrim($m[2], '/') : -1) );

    Now the 3 dots have disappeared and the markers are already displayed.

    • This reply was modified 8 months, 2 weeks ago by Carret.
    Thread Starter webitman

    (@webitman)

    @nickduncan thanks for the update to 8.1.3
    For most of my sites the problem does’t exist anymore.
    But I have 2 sites which faces still the problem.
    I’m looking into it and report later or tomorrow.

    @carret I have tried your solution too, but didn’t solve the issue. Thanks.

    @nesoor Do you use wordpress 5.6 too ?

    Thread Starter webitman

    (@webitman)

    @nickduncan cause FOUND !
    Security setting : Disable 5G Firewall. When enabled the issue occurs.

    This setting will implement the 5G security firewall protection mechanisms on your site which include the following things:

    1) Block forbidden characters commonly used in exploitative attacks.
    2) Block malicious encoded URL characters such as the “.css(” string.
    3) Guard against the common patterns and specific exploits in the root portion of targeted URLs.
    4) Stop attackers from manipulating query strings by disallowing illicit characters.
    ….and much more.

    if you have this issue in your security plugin disable 5G protection

    if you have this issue in your .htaccess remove the lines like below.
    # 5G:[WordPress]
    <ifModule mod_rewrite.c>
    RedirectMatch 403 /\$\&
    RedirectMatch 403 (?i)/\&(t|title)=
    RedirectMatch 403 (?i)/\.(bash|git|hg|log|svn|swp|tar)
    RedirectMatch 403 (?i)/(1|contact|i|index1|iprober|phpinfo|phpspy|product|signup|t|test|timthumb|tz|visit|webshell|wp-signup).php
    RedirectMatch 403 (?i)/(author-panel|class|database|manage|phpMyAdmin|register|submit-articles|system|usage|webmaster)/?$
    RedirectMatch 403 (?i)/(=|_mm|cgi|cvs|dbscripts|jsp|rnd|shadow|userfiles)
    </ifModule>

    Can someone confirm I am right ? @nesoor ?

    Error in Version: 8.1.3

    [13-Jan-2021 17:54:31 UTC] PHP Deprecated: Unparenthesized'a ? b : c ? d : e'is deprecated. Use either'(a ? b : c) ? d : e'or'a ? b : (c ? d : e)'in /[…]/wp-content/plugins/wp-google-maps/includes/class.rest-api.php on line 668

    The points remain on the map.

    If I deactivate the 5G firewall, the error disappears.
    The 6G can remain switched on.

    Best regards
    Thomas

    • This reply was modified 8 months, 2 weeks ago by Thomas.

    When I disable the 5G firewall the plugin indeed starts working again, thanks !

    Plugin Author NickDuncan

    (@nickduncan)

    @carret nice find there. I have patched this and an update will be going out today with that fix!

    @webitman thank you for letting me know about the 5G firewall. I’ll investigate and see if we can do a workaround here.

    @verathom an update will be going out today that will fix this issue

    Plugin Author NickDuncan

    (@nickduncan)

    Hi All
    Please update to 8.1.4 and let me know if your problems persist?

    Errors in Version: 8.1.4

    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: htmlParseEntityRef: expecting ';' in Entity, line: 99 in /[…]/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: htmlParseEntityRef: expecting ';' in Entity, line: 99 in /[…]h/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: htmlParseEntityRef: expecting ';' in Entity, line: 99 in /[…]h/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: htmlParseEntityRef: expecting ';' in Entity, line: 99 in /[…]/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: Attribute class redefined in Entity, line: 99 in /[…]/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: htmlParseEntityRef: expecting ';' in Entity, line: 99 in /[…]/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: htmlParseEntityRef: expecting ';' in Entity, line: 99 in /[…]/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: htmlParseEntityRef: expecting ';' in Entity, line: 99 in /[…]/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: htmlParseEntityRef: expecting ';' in Entity, line: 99 in /[…]/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109
    
    Warning: DOMDocument::loadPHPFile() [domdocument.loadhtml.php]: Attribute class redefined in Entity, line: 99 in /[…]/wp-content/plugins/wp-google-maps/includes/class.dom-document.php on line 109

    The points remain on the map.

    If I deactivate the 5G firewall, the error disappears.

    Best regards
    Thomas

    Thread Starter webitman

    (@webitman)

    @nickduncan After your update to 8.1.4 all my websites are working correctly.
    Thanks @nickduncan for your excellent plugin and support.

    Plugin Author NickDuncan

    (@nickduncan)

    Thank you @webitman

    I’ll make sure those warnings are removed in 8.1.5 @verathom

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘3 dots keeps circling’ is closed to new replies.