Support » Plugin: Elementor Website Builder » 3.5.0 update failed…just rollback to 3.4.8

  • Resolved aleksandartalic

    (@aleksandartalic)


    Hi i had issue as many here with new elementor update.
    I want to help to all readers, easiest way to fix this is go to Elementor-tools-manager versions.

    And rollback to 3.4.8 until they fix that bug with a new update.
    For me, half of the functions were not working, including toggle button.
    And update didnćt finish because server timed out. I tried manually to install new update through cpanel, still failed.
    Once i installed 3.4.8 previous version, all came back in function.

    So, until some new version comes out to try it, use the rollback to the old one.

    I spent 3 hours on this, just want to save your time.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Elementor Team

    (@ozyeger)

    Hi,

    Can you send me your site URL?

    Thread Starter aleksandartalic

    (@aleksandartalic)

    [ Use the link field next time ]

    //Here is my site, but currently it is running on 3.4.8 Elementor.//

    Plugin Support Elementor Team

    (@ozyeger)

    Hi,

    Try to follow this troubleshooting method that I made: (It’s quite general, but maybe it will tell us something.)

    Please make sure that all of your Plug-ins and Theme are updated.
    Sometimes it isn’t obvious that there is a plugin update available. Go to WordPress Dashboard > Updates and click the Check Again button to be sure.
    After you checked that you are really updated to the latest versions, and the issue still occurring:
    Please deactivate all your plugins besides Elementor and see if it helps. If it solves the issue reactivate them one by one to find the culprit. If it didn’t help, switch your theme (temporarily) and see if it makes any difference.
    Please also regenerate the CSS via Elementor > Tools > Regenerate CSS on your WordPress Dashboard,
    then make sure that you clear:
    your WordPress cache (your WordPress plugin if you have one), your server cache (if you have one. In this case, you can contact your hosting provider).
    Please Delete Elementor versions, then reinstall it.

    Plugin Support Elementor Team

    (@ozyeger)

    And also make sure to back up your site.

    Thread Starter aleksandartalic

    (@aleksandartalic)

    So, i tried all above, few times.
    I even used troubleshooting mode in Elementor, switched theme…nothing helped, now even in versions below 3.5.0 i was not able to open editor, and that started with first time i updated to 3.5.0.

    I did windows update, cleared all cache, rebooted my laptop, and downgraded again to 3.4.8, and at least now i can open my editor.
    Tested it on 3.5.0, i can open it there as well.
    However on 3.5.0 my toggle button doesnt work, and it is created with Elementors Header and footer builder…whole header is made in that plugin.

    So, it is clear that Elementors header and footer builder is not compatible witj elementor 3.5.0.

    I submited my App to Amazon store and it is under review, i had to switch back to 3.4.8 so my toggle is functional.

    There is no fresh updates for any other plugin, except Elwmentor now that os calling me again to 3.5.0.

    Please if Elementor Header and footer builder is your software, it needs to be updated to match with 3.5.0 code i guess.

    Plugin Support Elementor Team

    (@lianakap)

    Hi ,
    Thank you for the update.

    I am glad to hear that you could sort this out.

    our latest Elementor had some major upgrades and structural changes with the latest 3.5.0 version.

    The fastest way to solve your issue would be to roll-back the plugin.

    In addition, you can check our Changelog for further changes or updates: https://wordpress.org/plugins/elementor/#developers

    Thread Starter aleksandartalic

    (@aleksandartalic)

    Just update on this post.
    I see that Elementor header and footer builder came out, updated it…and tested 3.5.0 version.

    However all looks fine, and on mobile web all looks fine, only on my converted app Toggle Astra Canvas button stops working.

    But if the Astra is the issue it would not work even on web view.

    Not sure what might be the issue through the android app frame, probably some kind of whitelisting for frames or something.

    Reverted it back again to 3.4.8, i hope in future i will not have to stay on 3.4.8 version until the end of my life 😁

    wildflower24

    (@wildflower24)

    aleksandartalic thanks for the heads up, as u say, saves a lot of time when someone just makes it simple, there’s a problem with popups, menus, and more with last version of elementor, it would be great if elementor fix this in a new release and stop saying all users to test another plugins possible problems…

    Again, thanks 😉

    Plugin Support Elementor Team

    (@talmo)

    Hi,
    We have released a newer 3.5.1 with some fixes, please try the update and let me know if the issue persists there.

    Thread Starter aleksandartalic

    (@aleksandartalic)

    Hi
    Tested 3.5.1
    Still my button toggle menu, which is made with elementor header and footer builder is not working from Android app view

    Got an email from auto wordpress system that there is Fatal error with Elementor plugin in admin-ajax.php area

    Switchsd back to 3.4.8 and lower versions, all is working fine with them.

    So, for me 3.5.1 still didnt fix it, and obviously WP is pointing where the error is, so you can check that section

    Plugin Support Elementor Team

    (@talmo)

    Hi,
    Thank you for the reply.

    I appreciate you letting us know.
    We are fixing and debugging issues and will note this.

    You are welcome to follow our changelog –
    https://wordpress.org/plugins/elementor/#developers

    I am closing this subject, for now, please open a new one if this is not fixed within one week.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.