Support » Plugin: Smart Slider 3 » 3.2.13 is broken

  • Resolved AMIB

    (@amib)


    After updating to the latest version, The slide simply shows images without any effect,
    It seems that there are no JS, CSS loaded at frontend.
    Both widget and shortcode have the same problem
    I’ve reverted to the previous version and the problem is solved.

    • This topic was modified 4 years, 9 months ago by AMIB.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Gabor

    (@nextendweb_gabor)

    Hi @amib!

    We just implemented a new CSS and JS injecting code, because the previous one was always just patched when there was a conflict and we wanted to rewrite the whole thing properly.

    Please rather write to us to support@nextendweb.com about this, because we would need to do some deeper investigation about the issue! Also please send me a link to your website in your email!

    Plugin Author Nextendweb

    (@nextendweb)

    Hi @amib,
    we have created a debugging plugin which helps to identify the same issue you have. It would be great if you could install and activate the following plugin and then check the page which contains the error with the ?ob-test=1 query.

    Here you can get the plugin: https://wordpress.org/plugins/output-buffer-tester/

    For example http://test.com/my-page?ob-test=1

    If you see a detailed error message, please share it with us and we will be able to suggest solutions.
    If there is no error, please follow Gabor’s advice. Thank you!

    Thread Starter AMIB

    (@amib)

    Thanks for response

    These two sites have approximately the same config and plugin sets:

    This one with “output-buffer-tester” activated:
    https://sbstore.ir/design3/?ob-test=1
    that is OK with parameter being set

    and this one without that plugin, having problems:
    https://sbstore.ir/design1/
    NOT OK

    another thing that may help identify the problem,
    Our themes are all rendered using single index.php and there is NO “header.php” and “footer.php”.
    I thought that maybe help find the problem

    Plugin Author Nextendweb

    (@nextendweb)

    @amib, Please activate that plugin on the site you are having the problem and paste here the full error message with the call stack reported with red color. That will tell us what to suggest.

    Thread Starter AMIB

    (@amib)

    The first site has the problem
    but installing the extra plugin and setting the extra query var solves it.

    Both sites have the latest main plugin installed
    There is no error message visible after setting query var “ob-test=1”

    Plugin Author Nextendweb

    (@nextendweb)

    @amib, thanks, it clears. It seems like some of your plugin or theme unexpectedly closes the output buffers. Please reach me at support@nextendweb.com

    I would like to do some debugging steps and offer you the best solution for this case as that plugin meant to be for debugging and not the solution itself.

    Thread Starter AMIB

    (@amib)

    I found the problem, and solved it.
    The buffers were flushed in the theme for performance. This is fixed right now.

    Thanks for fast and good support.

    • This reply was modified 4 years, 9 months ago by AMIB.
    Plugin Author Nextendweb

    (@nextendweb)

    Great @amib,
    Could you send me your theme (when it was not working) in a zip file to me? roland@nextendweb.com

    I would like to improve our debugging tool and your theme could be a big help.

    Thread Starter AMIB

    (@amib)

    This was somehow an error in our custom made theme that can’t by solved by your plugin, You’d better insert the scripts and styles in the footer as it can prevent such conflicts with some other themes or plugins. and insert some minimum inline styles with HTML to keep the view nice before complete page load.
    This also makes the site get better SEO scores by google.

    This was the problem for our theme:

    ...
    </head>
    
    <?php flush(); ob_flush(); ?>
    
    <body <?php body_class(); ?>>
    ...
    • This reply was modified 4 years, 9 months ago by AMIB.
    Plugin Author Nextendweb

    (@nextendweb)

    Thanks! Smart Slider 3 can be placed anywhere and if we did not use this technique, then we would need to add Smart Slider CSS and JS codes to every page. With this method, we can make sure that resources are loaded only on pages where they are really needed.

    Thread Starter AMIB

    (@amib)

    It’s not reasonable for any theme or any plugin to use shortcodes or widgets after ‘wp_footer()’ function call.
    if doing so, there would be many problems with other plugins, So I think it’s the best idea to load scripts and styles at the footer not at the header.
    as I said before, putting some minimal inline css can create an acceptable loading indicator in the slider before footer scripts are being loaded.

    another technique that can be used to prevent page buffering would be loading the scripts and styles, just where the first slide is located in the page that has a pitfall, It prevents some caching plugins to detect and optimize the assets used by slider.

    Anyway, the problem is solved right now and doing techniques above may help a little to load pages more quickly and more SEO friendly.

    thanks !

    Plugin Author Nextendweb

    (@nextendweb)

    @amib, thanks. Probably we will add an options to enable usual enqueue in Smart Slider 3.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘3.2.13 is broken’ is closed to new replies.