Support » Plugin: Passster - Password Protection » 3.18 Update (Jan 13 2019) Error

  • Resolved djgrant181


    The latest upgrade toggles a 500 error:

    Parse error: syntax error, unexpected ':', expecting ';' or '{' in /*****/wp-content/plugins/content-protector/src/sessions/SessionHandler.php on line 32

    Line 32 is:

    32    protected function sanitize(string $key): string
    33    {
    34        return preg_replace('/[^A-Za-z0-9_]/', '', $key);
    35    }

    Please advise as to a fix.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter djgrant181


    I should add that this is with PHP Version 5.6.37




    Same here… after Update… plugin broken!

    Plugin Author patrickposner


    Hey @djgrant181 and @netspark,

    the main reason for this problem is the PHP version.

    Since the support of 5.6 has ended with 31 december 2018 (and for 7.0 as well) it’s highly recommended to upgrade to PHP 7.1 or later.

    If that’s not possible for you (hoster does not support the upgrade) I can provide you a compatible 5.6 version but this will require a couple of days.

    I wait for your answers and we find a suitable solution for both of you πŸ™‚

    Best regards,



    I can confirm that PHP5.6.37 does no longer provide support for the plugin. Lifting the PHP version to 7.1 solves the script problem.

    So check your webserver (and optionally .htaccess) for
    AddHandler php71-cgi .php

    This is mandatory. You may want to check ALL your plugins for compatibility with the new PHP version!

    Found on my WP installation 4 plugins that stopped working when raising the PHP version…

    Hope that helps

    P.S: Lifted to PHP7.3 and everything’s fine for now. Sometimes it’s necessary to do a cleanup on aisle 4! πŸ˜‰

    • This reply was modified 4 years ago by Netspark.


    Same problem here. Plugin breaks my site which is not yet PHP 7.1 compatible. I don’t know yet whether it can be made compatible in the short term so a 5.6 version of Passster would be highly appreciated in the meantime! Thank you.

    Thread Starter djgrant181


    This is what I suspected, had other plugins with issues also along the way due to PHP versions. My shared hosting will only go up to PHP 7.0 vice 7.1, is currently set at 5.6.37

    If it’s too much of a bother to have it available for PHP 5.6, don’t worry about it, I can probably find other work-arounds. That being said, if you want to provide a 5.6 version, I wouldn’t complain about it, either! πŸ™‚


    Thread Starter djgrant181


    I just changed to PHP 7.0.33, and it is working for me now.

    Only had one other (unused) plugin that broke, so all is well πŸ™‚


    Plugin Author patrickposner


    Hey @djgrant181,

    great to hear!

    PHP 7 has so much more powerful features and it is really good step to make if there are no dealbreaker plugins on your site.



    Hi @patrickposner,

    Can you provide a compatible 5.6 version? My client is currently working through an upgrade plan for their site but that won’t be pushed through for another month or so.

    • This reply was modified 4 years ago by laig95. Reason: typo


    Please create the PHP 5.6 version. Or provide the previous version number so I can downgrade to that version of the plug in and not update. Is the 3.1.6 version safe with PHP 5.6.37???


    • This reply was modified 4 years ago by rscalzo.
    Plugin Author patrickposner


    Hey @laig95 and @rscalzo,

    you can download the 3.1.7 version which is compatible with PHP 5.6.
    There will also soon the version available which is compatible with PHP 5.6 too

    Version 3.1.7:
    Scroll down to the bottom and click “Download”

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘3.18 Update (Jan 13 2019) Error’ is closed to new replies.