Support » Plugin: Passster » 3.1.6 breaks my blog

  • Resolved ernieg

    (@ernieg)


    Is the 3.1.6 zip file complete with all the required files? Updating to 3.1.6 broke my blog and installing 3.1.6 as a fresh new plugin fails to install.

    Error message:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in /blog/wp-content/plugins/content-protector/src/sessions/DatabaseHandler.php on line 120

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author patrickposner

    (@patrickposner)

    Hey @ernieg,

    thanks for your report.

    The files are complete, but I think there are some problems in your server configuration.

    Could you install https://wordpress.org/plugins/send-system-info/ and send your system log to hello@passster.io ?

    I check the log and follow up here.

    Best regards,
    Patrick

    Plugin Author patrickposner

    (@patrickposner)

    Hey @ernieg,

    I found the problem.
    You absolutely need to update your PHP and MySQL version of your server (or let your hoster do this).

    You use an very old version of both (PHP 5.3.6 and MySQL 5.1) even WordPress itself recommends PHP 7 (better 7.1 or 7.2) and a minimum MySQL of 5.6.

    Have a look here:https://en-au.wordpress.org/about/requirements/

    Since your version got their last support update many years ago you should immediatly update, since there are several unfixed security issues in these.

    btw: Passster requires a minimum of PHP 5.6 to work probably, if you have done the update, the notice will never come along your way again:-)

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.