Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » 3.1.11 and 3.1.14 uploads via XMLRPC API are broken

  • Resolved alloyphoto

    (@alloyphoto)


    Starting with 3.1.11 there are fatal errors when trying to upload an image using XMLRPC API. Your PHP code throws exception in package.module.nextgen_xmlrpc.php starting from line 1305. Problem is that upload_base64_image returns an integer image ID wile the rest of the code expects the result to be a C_Image object. Please fix ASAP as this affects many customers who use my Lightroom plugin.

    Thanks
    Vladimir

Viewing 6 replies - 1 through 6 (of 6 total)
  • Yes – This is a serious issue. I’ve been very pleased to use Alloyphoto’s Lightroom plugin with NextGen Pro for a number of years and hope that the NextGen folks will be responsive here. Thanks to all involved for looking into it. Cheers! John

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @alloyphoto

    Our developers have already fixed that in code. It will be released next week.
    If you want, we can provide you the beta version.

    Please contact us referring back to this forum thread and mention that Gaby referred you https://www.imagely.com/contact/

    – Gaby, Customer Support.

    I tested version 3.1.17, which still doesn’t work

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @michaelmoody-1

    We have a beta version of the plugin with the fix.
    Would you like to give it a try? If so, please send us a bug report here: http://www.imagely.com/report-bug, refer back to this forum thread and let them know Gaby referred you.

    Please, do not forget to add the link to this forum and ask for NextGen Gallery V 3.1.15

    Thanks!

    Plugin Support gabyimagely

    (@gabyimagely)

    This particular issue seemed to be solved by installing the latest version of our plugin.
    Nevertheless, we have a special case that has been registered as a bug report.

    Not correct, still not working

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘3.1.11 and 3.1.14 uploads via XMLRPC API are broken’ is closed to new replies.