Support » Plugin: WooCommerce » 2nd time installing woo commerce storefront failed

  • Resolved inspiritarts

    (@inspiritarts)


    Hello WordPress world,
    After installing and deactivating woocommerce’s storefront plugin, I got this error message that the installation failed the second time I attempted to install the same plugin that worked the first time.

    Unpacking the package…

    Installing the plugin…

    The package could not be installed. No valid plugins were found.

    Plugin installation failed.

    Return to Plugin Installer

    On another thread, somebody posed this suggestion, but never explained how to resolve the issue.

    “The problem was that the plugin couldn’t be deactivated then activated again. This was because the table creation failed if the underlying tables already existed (because the plugin was previously present then deactivated).

    I appreciate the updated files you provided which bypass the table creation on activation. The activation now works, and the plugin is also working well again.”

    This sounds like a reasonable explanation. Would anybody know what I should do to get the plugin installed a second time?

    • This topic was modified 3 months, 1 week ago by  inspiritarts.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Oops. I feel so silly.
    Turns out that I simply had to activate the theme in the appearance tab. All is well. Sorry to bother you.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.