Support » Plugin: Max Mega Menu » 2nd level Menu doesnt work after update to WP 4.8

Viewing 10 replies - 1 through 10 (of 10 total)
  • albertok

    (@albertok)

    I explain better…

    In the 2nd level menu doesnt work properly hover Transitions I have set in:

    Max Mega Menu – Menu Thems – Hover Transitions

    Menu Themes - Hover Transitions

    • This reply was modified 3 years ago by albertok.
    • This reply was modified 3 years ago by albertok.
    Plugin Author megamenu

    (@megamenu)

    Hi albertok,

    Which plugin/widget were you using to display the widgets in the sub menus? (e.g. JetPack images widgets, Image Widget by modern tribe, a different one?)

    Is that plugin still active on your Plugins page?

    Also check the Appearance > Widgets page. WordPress itself – usually when switching themes – will move widgets from their existing positions and put them in the “Inactive Widgets” sidebar. So you would need to find those widgets in the “Inactive Widgets” sidebar and drag them back over to the “Max Mega Menu Widgets” sidebar.

    Regards,
    Tom

    albertok

    (@albertok)

    Hi @megamenu
    Thank you very much for your answer 🙂

    I;m actually using a widget named “visual editor” (Black Studio TinyMCE Widget)
    However is my intection to use new WP 4.8 Advanced Text Editor widget

    <a href="http://www.radiotusciaevents.com/rubriche/a-tutto-volume/" target="_blank" rel="noopener noreferrer"><img class="aligncenter wp-image-2843 size-thumbnail" src="http://www.radiotusciaevents.com/wp-content/uploads/2017/03/A-TUTTO-VOLUME-150x150.png" alt="a tutto volume" width="150" height="150" /></a>
    

    This is what you find inside every single menu item

    There are in the first menu voice named “Rubriche” (first on the right of HOME voice) 2 rows of widget named #visual Editor”. every row has 5 “Visual editor” widget and inside of eachone a code similar as you see before.

    There are no “Visual Editor” widget in “Inacive widgets”;

    All item are visible but it doesnt work Hover transations

    • This reply was modified 3 years ago by albertok.
    Plugin Author megamenu

    (@megamenu)

    Hi albertok,

    I see the images now.

    The “Hover transitions” option means the hover background/font color of the menu items will quickly fade in and out on hover (e.g. the red background on your top level menu items), but as it says in the option description, it does not work if you have gradients set for the colors.

    Therefore, you’d need to set a solid background hover color on the top level items if you want to see the background fade in and out (it wont be applied to the images as there is no background color/hover transition on widgets within mega menus – only for “genuine” menu items).

    Regards,
    Tom

    • This reply was modified 3 years ago by megamenu.
    • This reply was modified 3 years ago by megamenu.
    albertok

    (@albertok)

    Hi @megamenu,

    really thanks for your answer.
    I set as you said; but however hover transition doesnt work 🙁

    Plugin Author megamenu

    (@megamenu)

    Hi Albertok,

    I see you have the hover transitions working on the top level items now that they’re using a solid color.

    I wouldn’t expect to see any transition effect on the images as they do not have a background applied to them at all, nor do they have a hover state. The hover transitions only work for actual menu items (whereas the images are widgets – not menu items).

    To apply a hover effect to those you would need to use some Custom CSS (not something we cover under support sorry, as it’s not a feature). It is very complex to do but this could be a starting point for you:

    https://codepen.io/nxworld/pen/ZYNOBZ

    Regards,
    Tom

    albertok

    (@albertok)

    Hi @megamenu

    sorry for my late answer but on 06.13 they have left me without internet connection… Now Ï get it! 🙂

    As far as my issue is concerned:
    Before WP 4.8 update the hover transitions worked perfectly on Mega menus and overall on images. now It doesn’t work anymore!
    Actually images are inside the default text-widgets of WP

    Herewith enclosed you can find my Mega Menus settings; Have I maybe set something wrong?

    MaxMegaMenu Settings 01/04

    Max Mega Menu settings 01/04

    MaxMegaMenu Settings 02/04

    Max Mega Menu settings 02/04

    MaxMegaMenu Settings 03/04

    Max Mega Menu settings 03/04

    MaxMegaMenu Settings 04/04

    Max Mega Menu settings 03/04

    Thanks in advance for your help… and patience 🙂

    • This reply was modified 3 years ago by albertok.
    • This reply was modified 3 years ago by albertok.
    albertok

    (@albertok)

    Maybe images are not so clearly displayed?

    • This reply was modified 3 years ago by albertok.
    • This reply was modified 3 years ago by albertok.
    Plugin Author megamenu

    (@megamenu)

    Hi Albertok,

    MMM has never applied it’s own styling to widgets/images. It only applies (and only ever has applied) styling to actual menu items. So I am not sure where your hover effects on images were coming from previously, but it wasn’t MMM. Maybe they came from your theme, and updating your theme wiped them out, but I can’t say for sure sorry.

    Regards,
    Tom

    albertok

    (@albertok)

    Hi @megamenu
    Really thanks for your patience and quick answer! 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘2nd level Menu doesnt work after update to WP 4.8’ is closed to new replies.