Support » Plugin: Wordfence Security - Firewall & Malware Scan » 2FA Prompt Not Appearing

  • Resolved redfernfarm

    (@redfernfarm)


    Help! I just enabled 2FA for my WordPress website. I logged out so I could log back in and try it out, but after I put in my username and password and click “Log In” nothing happens–I don’t receive a prompt for the 2FA code so I’m effectively locked out of my site.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same thing happens for me both on paid wordfence subscriptions domains and free wordfence domains. I have lodged a ticket for the paid wordfence domain but also would like a solution for the free wordfence usage. The only workaround I have at the moment is to disable the Wordfence plugin from the host back end but this is not appropriate for other web sites I assist with that I do not own. Please someone sort this out or update your documentation at https://www.wordfence.com/help/tools/two-factor-authentication/ because your suggested work around does not work for the issues I am experiencing. Also I am not in a position to use the Health Check & Troubleshooting Plugin as numerous sites are live.

    I have a similar issue – not sure if it’s what you’re experiencing but in my case the ‘2FA code?’ prompt is in white text and my login box is on a white background. I’ve tried adjusting the CSS to try and override it to no avail. The code that’s applying it is:

    .login #nav, .login #backtoblog a, .login #nav a, .login label, .login p.indicator-hint {color: #ffffff!important;}

    You do get the box and the question icon with the tooltip, but the text can’t be seen unless its highlighted.

    My issues were resolved after it was discovered that I still had reCaptcha version 2 on the affected domains, and it was causing a scripting problem for 2FA and login verification. When I updated to reCaptcha version 3 the conflict disappeared and both began to work fine.

    Hmm…Unfortunately I don’t think I can use v3 as Gravity Forms doesn’t support it yet and I use GF for my registration process.

    The functionality of the 2FA is working fine though, it’s just the missing text label as far as I can see.

    Plugin Support wfscott

    (@wfscott)

    @redfernfarm

    I apologize for the delay.

    Have you been able to successfully log in to the site?

    If not, you will want to use FTP or file manager to rename the wordfence folder in wp-content/plugins

    After you do that, you can go ahead and login. Once logged in, rename the plugin back with the same method and then go into Wordfence > Login Security and remove the 2FA for the time being. We can then look and see what is causing the issue. I would initially think conflicting plugin or theme.

    Let me know if you’re able to get back in and we can go from there.

    @wfscott

    After my initial panic, I did realize I could go into file manager and delete the plugin, so that’s what I did in order to get logged in again. When I reinstalled the plugin, somehow 2FA was still enabled (not tech savvy enough to know why that would be, since I deleted the entire folder) but this time around it worked–once I entered my password it took me to the next page with the 2FA prompt. (Which is what wasn’t happening before.) Since I still had the authenticator app set up on my phone, I was able to log in just fine and it’s been working as intended since then.

    This entire sequence of events happened without me changing anything else (themes or other plugins) so I have no idea why it works now when it didn’t before, but I’ll take it.

    Plugin Support wfscott

    (@wfscott)

    @redfernfarm

    That is interesting, but I’m glad that the login flow is working correctly for you now! Please feel free to reach out if you run into any other issues.

    Scott

    Same here.

    In the first test the page with the input field for the 2FA Code does not appear. Just an error message “Code required . Please provide your 2FA-code

    Deleted the WF files and .htaccess entries. Installed WF again, works.

    If you need additional information, contact me.

    Anyway: Thank you for this Plugin. It’s essential.

    Additional info: I am using WooCommerce. Login via account-page displays the message “CODE REQUIRED: Please provide your 2FA code when prompted.

    No Problems with the page example.com/login

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.